5ghz preference

  • 3
  • Question
  • Updated 11 months ago
  • Answered
Is there any way to steer client devices toward using the 5ghz band rather than not offering 2.4 on the access point? Almost all of the devices in our network tend to connect at 2.4 even though they're perfectly capable of 5.
Photo of leehancock

leehancock

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 3
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Here's a great video discussion of Band Steering - which is the feature you're looking for:

https://www.youtube.com/watch?v=yFLwdP...

Photo of Ram

Ram

  • 29 Posts
  • 5 Reply Likes
Lee, there will always be adamant clients which won't get steered to 5ghz even though there is 5ghz WLAN available as preference is set to 2.4 ghz on those clients however in some clients i have noticed that you can tweak this behaviour by making 5ghz as default.
Or set the 5G band as a different SSID.
or if this is specific AP area issue then you can just turn off WLAN service for that ZD controlled AP for 2.4 ghz so that client will be auto forced to connect to 5ghz.

Hope this helps.
Photo of Ram

Ram

  • 29 Posts
  • 5 Reply Likes
Our Bandsteering feature is enabled by default on our controller and this feature is not available on standalone mode.
Photo of Peter Dohm

Peter Dohm

  • 13 Posts
  • 1 Reply Like
Ram, any ideas if this feature is ever going to make it into standalone mode?
Photo of leehancock

leehancock

  • 2 Posts
  • 0 Reply Likes
Thanks for the information. We have a bunch of Wyse c90le7 terminals with 802.11n cards that I just cant ever get to connect on the 5ghz band. I checked in the driver options and there's no setting for preference.
Photo of Ram

Ram

  • 29 Posts
  • 5 Reply Likes
If they don't get bandsteered and no configuration option in WNIC then making 2.4 ghz wlan NOT available is another option to ponder upon.
Photo of Bittu

Bittu, Employee

  • 43 Posts
  • 13 Reply Likes
The best method to check if the problematic clients connect to the 5 GHz network is to deploy an SSID specifically on the 5 Ghz radio of the AP and check if the client is able to connect successfully.
To do this, create a Test SSID and under WLAN Group create a New group and enable only this Test SSID under this Group. Please ensure that this Test SSID is unchecked under Default WLAN group's. Once this is done you will have to deploy this WLAN group on the AP, this can be done under Configure > AP > Select the AP on which you want to deploy the SSID > WLAN Group > Select the Test WLAN group that was created by you.

We do band steering via two ways as below:

Refusing Authentication and process is outlined as below
If client requests authentication on 2.4 GHz, and
AP previously detected the client on 5 GHz, and
Client does not appear to be in distress
Sufficient RSSI [set for this WLAN on 5ghz via CLI] on 5 GHz within the past minute, or else
Sufficient RSSI [set for this WLAN on 2.4 ghz via CLI] on 2.4 GHz within past minute, and
AP is not a Mesh AP, then
Refuse authentication on 2.4 GHz.

Withholding Probe Responses and process is outlined as below :

If client is probing on 2.4 GHz, and
AP previously detected the client on 5 GHz, and
One of the following:
AP has not detected probes from client in past minute, or
Client does not appear to be in distress (see Auth Refusal), and
AP is not a Mesh AP, then
Withhold probe response on 2.4 GHz
Note: clients try to authenticate even when the AP does not respond to its probes, so withholding probe reponses is not sufficient to steer clients.

Some AP and ZD CLI commands to end this topic.
AP CLI:
get band-steering-rssi-thresh wlan
set band-steering-rssi-thresh wlan
ZD CLI
remote_api_cli -A “get band-steering-rssi-thresh wlan”
remote_api_cli -A “set band-steering-rssi-thresh wlan ”

Hope this helps, all the best.
Photo of brent sergent

brent sergent

  • 6 Posts
  • 1 Reply Like
Note the remote command from ZD is remote_ap_cli ( -A is all AP's) 
The band steering command isn't available either on AP or ZD in later versions or not at all.
Photo of Chris F

Chris F

  • 2 Posts
  • 0 Reply Likes
Is there any way to disable band-steering?

We have a lot of handheld terminals running Windows CE and have constant client connectivity issues whenever we use 5Ghz. I'd rather not remove 5Ghz (current workaround) if I could disable band-steering to see if this is the cause....
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
This is a great conversation that's separate from the main topic, so I created a new topic to continue the discussion. Please reference the new topic here: Is there any way to disable band-steering?
Photo of DRC

DRC

  • 16 Posts
  • 9 Reply Likes
Had to do exactly this a while back...one AP was mounted in an area where 2.4GHZ is just terrible (non wi-fi interference that can't be removed...long story).

Created another WLAN that is 5GHZ only (i.e. disabled 2.4GHZ Radio)

I called the SSID "DPC Wi-Fi 5GHZ".
The original 2.4/5 WLAN remains; SSID is still "DPC Wi-Fi".

Had the clients I want to connect to 5GHZ only connect to "DPC Wi-Fi 5GHZ". Works great.

PROS: it works
CONS: minimal overhead because now there's two WLANs instead of one. HOWEVER, it's very minimal, nothing that can't be handled effortlessly.
Photo of DSE

DSE

  • 55 Posts
  • 3 Reply Likes
Hello DRC, but how you really configured that?
u only use a 2 group the default and an 5ghz correct?
where in the 5ghz group u only deploy the ssid of 5ghz, but my doubt is how u really configure the ap group without the 2.4 ? and still have it working with the DPC Wi-Fi on 2.4 ?
Photo of DRC

DRC

  • 16 Posts
  • 9 Reply Likes
Hello Nuno,

I. RE: "how you really configured that", here are the actual steps:

1. Configure > WLAN > WLANs - Create new > DPC Wi-Fi 5GHZ > OK
2. Configure > WLAN > WLAN Groups - Create new > 5GHZ > Check DPC Wi-Fi 5GHZ > Uncheck DPC Wi-Fi > OK
3. Configure > WLAN > WLAN Groups - default - edit > Members - check both DPC-Wi-Fi 5GHZ and DPC-Wi-Fi > OK

4. Configure > Access Points > ap in question - edit > Radio B/G/N (2.4GHZ) - check WLAN Group > Select Default > Radio A/N (5GHZ) - check WLAN Group > Select 5GHZ > OK

II. Correct
III. That's how I configured it.
IV. Yes sir, DPC Wi-Fi clients connect on 2.4GHZ only because this is the only SSID enabled on 2.4GHZ radio. Vice versa with DPC Wi-Fi 5GHZ, which is the only SSID enabled on the 5GHZ radio.

I am using ZD1100 9.3.4.17, and six zf7962 for this example. Fire up a channel analyzer, and you'll see DPC Wi-Fi only on 2.4 channels, and not on 5GHZ channels, and vice versa for the other SSID.

Hope this helps you.
Photo of pcjfx

pcjfx

  • 2 Posts
  • 0 Reply Likes
So the only way to truly do this I am seeing,,,,, is to disable 2.4 on selected radios???
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Or change the client if it's possible :)

But yes. 100% is if you turn off 2,4GHz radio on an AP.
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
What values would you change to cause more aggressive band steering.

"Some AP and ZD CLI commands to end this topic.
AP CLI:
get band-steering-rssi-thresh wlan
set band-steering-rssi-thresh wlan
ZD CLI
remote_api_cli -A “get band-steering-rssi-thresh wlan”
remote_api_cli -A “set band-steering-rssi-thresh wlan ”