Skip to main content

4 Messages

 • 

122 Points

Mon, Aug 3, 2015 1:48 PM

Unable to invoke the secure hotspot XML Api

HI,

I'm trying to test the sample secure hotspot with ZD1200. 

User authentication from ZD fails dues to the following SSl error. Here in xmlcommon.py tries to call https://:443/admin/_port.... Northbound portal interface is also enabled and the password is also correct in the payload. 

Unknown SSL protocol error in connection to :443

I tried to debug the ssl error with openssl and below is the result.

$ openssl s_client -connect :443 -debug

CONNECTED(00000003)

write to 0xe684c0 [0xe68a60] (295 bytes => 295 (0x127))
0000 - 16 03 01 01 22 01 00 01-1e 03 03 19 53 08 86 6f   ....".......S..o
0010 - 1d ab a4 9e 7d 15 61 92-e8 c1 0d 47 48 b6 0d f8   ....}.a....GH...
0020 - 88 1f 46 80 30 ce 54 96-33 78 fc 00 00 88 c0 30   ..F.0.T.3x.....0
0030 - c0 2c c0 28 c0 24 c0 14-c0 0a 00 a3 00 9f 00 6b   .,.(.$.........k
0040 - 00 6a 00 39 00 38 00 88-00 87 c0 32 c0 2e c0 2a   .j.9.8.....2...*
0050 - c0 26 c0 0f c0 05 00 9d-00 3d 00 35 00 84 c0 12   .&.......=.5....
0060 - c0 08 00 16 00 13 c0 0d-c0 03 00 0a c0 2f c0 2b   ............./.+

read from 0xe684c0 [0xe6dfc0] (7 bytes => -1 (0xFFFFFFFFFFFFFFFF))
write:errno=104
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 0 bytes and written 295 bytes
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
---

Any idea why this is failing?

Responses

No Responses!