T

4 Messages

 • 

100 Points

Tue, Nov 2, 2021 8:42 AM

Disable the redirect page and 3 second timeout during captive portal redirection

Hi all, just bought a ZD1200 with 7x T610s for my

wifi project  , after setting it up using WISPr with external web portal

and installed SSL certs to the ZD , everything seems working but

there is one thing bugging me which is the initial http redirect.

When I tried connecting to the Hotspot, the browser shows up and

there is a redirect message on the browser " If you are not redirected within

3 seconds, please click" , is there any way to remove the irritating

redirect text and shows my captive portal instantly (without the 3 second wait)

once the client connect to my hotspot? I cannot find any way to change these setting

in the ZD web GUI.

Thank you guys for your help

Official Rep

 • 

1.4K Messages

 • 

18.4K Points

2 m ago

If portal page is hosted from external server, I don't think that page is coming from ZD.

Could you add a screenshot.

4 Messages

 • 

100 Points

2 m ago

Please see the link below, he has the exactly same problem as mine, though the post is a few years old

https://forums.ruckuswireless.com/conversations/zonedirector/3sec-delay-time-at-using-wispr-ssid-on-zd-101x/5f91c3e1135b77e2478c557c

(edited)

Official Rep

 • 

274 Messages

 • 

4.6K Points

2 m ago

Hi @tommy_ip 

Could you please confirm the complete version running on the ZD?

Also, do you have any Rate limit enabled on the SSID?

When the client connects to the SSID, it needs to load certain files from the captive portal in order to display the Web page. And if you have any lower rate limit is enabled, loading these files takes time and due to that the client sees the delay message.

This is fixed in 10.3.1 version.

Regards,

Sanjay Kumar

4 Messages

 • 

100 Points

2 m ago

The ZD is running 10.3.1.0 build 42 firmware,

and we have rate limit enabled at 5mbps ,

so you mean we have to disable the rate limit

in order to get rid of the redirect message?

Thank you for your help

Official Rep

 • 

274 Messages

 • 

4.6K Points

2 m ago

Hi @tommy_ip 

Can you try disabling the Rate limit and see if it works?

If yes, then try increasing the Rate limit and check.

If the above 2 step works, then I would suggest you to open a support case so that we can investigate on this.

Regards,

Sanjay Kumar

Important Announcement