Skip to main content

6 Messages

 • 

120 Points

Tue, Feb 25, 2020 5:24 AM

Captive portal for Guest access is not working with IP address

Hello techies,
I am very new to Ruckus. In my company, they are using ZD1200 firmware Version
10.0.1.0 build 35. There are two SSIDs are running in the network one for staff members and one for Guest users, both SSIDs are configured with captive portal.
Now the issue is with guest SSID when a user connects to guest SSID will redirect to an FQDN but this domain name is not resolved and displays "page not found" error. In case If the user types the IP address of the controller manually, it will work fine. This redirection is working fine with FQDN in staff SSID. Please help me with this.

Responses

246 Messages

 • 

4.2K Points

8 months ago

Hi Girarj,

I believe you are using "Hotspot Service (WISPr) in the WLAN for both Staff and Guest SSID.

If yes, have you compared the settings between 2 SSID\2 hotspot profiles like, Isolation settings, Restrictions if any, Wallgarden list allowed?

What is the software version you are running on?

6 Messages

 • 

120 Points

8 months ago

Hello Sanjay,
 Hotspot and Hotspot 2.0 are not configured, I have checked both tabs are blank.
Software version 10.0.1.0 build 35.

246 Messages

 • 

4.2K Points

8 months ago

Hi Girarj,

I wanted to make sure since you mentioned Captive portal.

Can you check on both the SSID and confirm what is the option set for "WLAN Usages"?
I guess "Standard" for Staff and "Guest Access" for Guest SSID.

6 Messages

 • 

120 Points

8 months ago

Hello Sanjay,
You are right this time, options are set as same as you have mentioned.

246 Messages

 • 

4.2K Points

8 months ago

Hi Girarj,

That means, there is no redirection concept for the staff SSID. Only Guest SSID clients should get the redirection page of ZD. 

When the user connects and gets the redirection page, is it http or https? When you are entering the ip address, is it connecting as http or https?

I would recommend you to open up a support ticket so that the technical team can assist you. Below is the link to contact us.

https://support.ruckuswireless.com/contact-us

6 Messages

 • 

120 Points

8 months ago

Hello Sanjay,
Both are running over http.

6 Messages

 • 

120 Points

8 months ago

Hello Sanjay,
Users for staff SSID are also getting authentication prompt, and this redirection is working over http. I am sharing a screenshot for the same.

507 Messages

 • 

8.9K Points

Hi Girarj,

Could you please provide below details.

1- Screenshot of both WLANs (staff and Guest)
2- Is the VLAN for Staff and Guest is different?
2.1 - If yes, is there any firewall in network path?
2.2 - If firewall is there, could you please make sure that you have same set of firewall rules for working VLAN (Staff) and non-working VLAN (Guest). If both WLANs are on different VLAN.

Regards,
Syamantak Omer

246 Messages

 • 

4.2K Points

8 months ago

Hi Girarj,

It would be best to create a support ticket so that we can help on this.
We might need to check the setup config and understand the flow.

30 Messages

 • 

472 Points

8 months ago

Hi Girarj,
can you try this command on one of the APs and paste here the output?
get dns-cache get-ipaddr  

It seems a problem with DNS resolution to external portal.

Thanks.

David.

6 Messages

 • 

120 Points

Hello David,
It show "OK"  when I run that command.

rkscli: get dns-cache get-ipaddr nbcwifi.nbcbearings.in
OK