S

2 Messages

 • 

80 Points

Mon, Jun 7, 2021 11:35 PM

Unleashed: Perpetually-Connecting ICX7150

Hi all,

Lennar Homeowner here...I've searched, but don't find this.

I got the standard-issue gear a lot of Lennar buyers got, and the whole things is a bit of an adventure.  That means two R510 APs, running together as an Unleashed network for a few months.  Also included was an ICX7150, but nobody was able to tell me how they configured it or what account I should use.  So it was reset time this weekend.

The APs got the 200.10.10.5.229 upgrade, and they're still behaving.  I gave the ICX a hard factory reset, then upgraded the firmware to SPS08090j.  I made sure LLDP was enabled, and it seemed to help make the APs aware of the switch.  In fact, Unleashed found the switch and changed the admin username/pass to my main Unleashed account.  But that's as far as we've gotten.  For the past 24 hours or so, the status has been "Connecting" and I went into Unleashed and decided to remove the switch, wait a while, then manually add it.  Since I get prompted for my username/password, I figured that would help.  Instead, I can tell from the ICX logs that Unleashed is still trying to use the Super account. 

So what's the best way to get things moving along?  I can't change the password for the Super account, and am willing to whack the whole config in order to get the switch to join.  Unleashed doesn't seem to care if I give it different credentials, so it's going to keep trying Super.  I'm grateful for any help.  Thanks!

  

Official Rep

 • 

1.3K Messages

 • 

17.7K Points

6 m ago

2 Messages

 • 

80 Points

Thanks for the warning about versions.  I'll jump on updating the switch, as long as I'm poking at it.

I did find a fix, and it's probably something that has caused this same problem for others.  The deal is that my user account for Unleashed is an email address.  I think maybe the scripting going on inside the master AP is making the same mistake I made:

If I want to open an SSH connection to a host, the command is "SSH username@hostname" but that doesn't work with an email address as the username like, "SSH user@maildomain@hostname." This is exactly what the AP is trying to do.  It's easy to use the "-l" (lower-case L) switch if you're a human and not running on hard-coded scripts: "SSH -l user@maildomain hostname"

Since I'm not able to modify the AP's connection string, I created a new Unleashed admin user and then added the same user/password to the switch.  The new username is just a single word, not an email address.  Once I got those created, it took less than a minute for the switch to get joined to the Unleashed network.

It might not be a bad idea to modify that connection string in future firmware updates.  It's pretty common to use email addresses as usernames for cloud-based services, and I imagine I'm not the first person to run into this issue.

Important Announcement