B

15 Messages

 • 

238 Points

Wed, Aug 18, 2021 9:24 PM

Unleashed 20.10.10.5.x + Mesh + Rachio (DHCP broadcast bit)

I have an interesting problem that seems to be present in the 200.10.10.5.x (x=229 or 246) release. My Ruckus network consists of 3x hardwired 750's and 1x mesh connected R720. The R720 only serves a handful of clients in and around my detached garage, one of whom is a Rachio irrigation controller. The Rachio does associate with the appropriate WLAN but it never gets an IP address. I run the Troubleshooting tool from the Unleashed dashboard and I see that it sends a 'DHCP DISCOVER' packet. When I packet sniff on my pfSense router(also DHCP server), I see that the DHCP DISCOVER is received and the DHCP OFFER is sent back via the LAN to the Ruckus APs. However, I don't see the DHCP OFFER in the Troubleshooting debug picture on the Ruckus dashboard. So the Rachio just retries the DHCP DISCOVER ~4 times before resetting the interface and starting all over again. From it's perspective, no DHCP server ever replied.

The Rachio is the only device out of 50-60 devices in the house that has this issue. What makes the Rachio special is that the DHCP DISCOVER packet apparently has the BROADCAST bit set. This is somewhat unusual from what I gather reading the Rachio forums. (https://community.rachio.com/t/rachio-gen-3-frequently-offline-dhcp-failure/29083/7)

Now here is where is involves Unleashed. If I turn off the R720 and thereby rely on the wired R750's, the Rachio is as happy as a clam. Meaning that it receives the DHCP OFFER packet from my DHCP server via the same WLAN as served by the R750.

So it would appear that the DHCP OFFER packet (with broadcast bit set) is being filtered by the mesh component of Unleashed. Diving in there is only 1 direct option that I can see for this in the GUI (ARP Broadcast Filter in Admin & Services/System/Mesh). The option is not selected. The only other option that I experimented with and changed from the default is the Directed MC/BC Threshold (WiFi Networks/WLAN/Edit/Advanced Options/Others). I have set it to 0 from 1 (default) thinking that it will prevent the AP from converting group-addressed data traffic to unicast. 

Bottom line, with my R720 enabled utilizing mesh connectivity, my Rachio controller never hears the DHCP OFFER packet. With the R720 disabled, it easily gets its IP address from a R750. And this behavior is new with the 200.10.10.5.x versions. With 200.9... it was working fine. 

I can provide more logs, screen shots, etc if that would be helpful in diagnosing this problem with Unleashed mesh. 

Official Rep

 • 

1.2K Messages

 • 

17K Points

1 m ago

Hi Bhusan,

You have nicely explained the issue but this issue can only be further troubleshoot if you contact support.

This may required collecting AP packet captures, AP logs on root and mesh APs to see exactly where packets are dropping.

If you want to do advance level troubleshooting, you can setup wireshark and stream the captures from Ruckus APs to it. Below is the command.

set capture wifi1 stream  - for 5G radio

set capture wifi0 stream  - for 2.4G radio

Once above is done, add the AP IP on wireshark under Capture >> Options >> Input >> Manage Interfaces >> Remote interface >> Click on "+" sign >> add AP IP and hit "Ok".

This will fetch all the interfaces available on access point and you can choose which interface you want to monitor.

wifi0 - for 2.4 G radio

wifi1 - for 5 G radio

br0 - Bridged logical interface

ethx - Physical eth interface (eth0, eth1, etc)

wlanx - WLAN interface. Each WLAN will have two interface, one on 2.4G and one on 5G.

Pull the non working captures and see what you can find.

2 Messages

 • 

70 Points

4 d ago

Hi Bhusan,

Any chance you were able to resolve this?  I am seeing the same thing on my network with a very similar setup with the main difference being that I have a switch hanging off the remote (wireless) mesh AP.  Clients on the switch have the same issue with DHCP failing and I see the same packet behavior where the DHCP OFFER is sent from the DHCP server, but not received across the wireless mesh.

Thanks!

15 Messages

 • 

238 Points

@john_dennis Unfortunately I have not had the time to follow-up with the additional debug as suggested by @syamantak_omer . I don't have a support contract in place so contacting support might not work for me. It's on my to-do list but given that I have only one device that is misbehaving, not as high a priority. 

2 Messages

 • 

70 Points

@bhusan_gupta I have an open support case for this.  Hopefully we get it resolved so I can pass the information on to you.  Thanks for the reply.

Important Announcement