B

20 Messages

 • 

404 Points

Thu, Aug 12, 2021 7:49 AM

new firmware 09.0.00 issue for upgradation

hi Team,

i am using ICX7450 switch with L3 feature.

now before start the upgradation i am using the below version.

SPR08090d.bin (UFI)   SW: Version 08.0.90dT213

Compressed Secondary Boot Code size = 786944, Version:10.1.15T215 (spz10115)

after i upgraded the flash from 08.0.90d to 09.0.00T213.  we have facing issue for login after boot the image sec. . see below.

can you please check this error and let us know.

Starting kernel ...

bcmiproc-gmac 18023000.ethernet: can't find MAC address
Mounting file system...
booting with 4.4 kernel
PLATFORM SP
sd 0:0:0:0: [sda] No Caching mode page found
sd 0:0:0:0: [sda] Assuming drive cache: write through
SP's eUSB-Infra Called 
 Number of eUSB partitions 3 ...
PLATFORM SP
Config partition mounted.
eUSB flash drive is ready  No External USB Drive(s) Mounted . Successfully read the SKU Reg, the value is: 0xff
dma_mem_base: 0x96000000, dma_mem_len: 0x8000000, warm_mem_base: 0xdf500000, warm_mem_len: 0xb00000
Please download UFI image to install packages
/etc/process_packages.sh: line 153: can't create /.pkg/error.log: nonexistent directory
Package installation is incomplete, related functionalities may not be available
Cannot boot FastIron application due to package installation failure
starting console application
server-execvp: python3: No such file or directory



OS> 
OS> en
Unknown command 'en'.

Accepted Solution

Official Rep

 • 

141 Messages

 • 

4.3K Points

5 m ago

HI Bharat,

Hope you are doing great.

Going forward from 8090x onward we support single image ONLY.
You cannot have two images this causes issues with boot monitor.
Also we need to step upgrade.
First upgrade to 8080f non UFI image

then relaod,

then do a write mem,

then upgrade to 9000 image on both flash.

Hope this helps.

Thanks

Hashim

27 Messages

 • 

664 Points

5 m ago

I see you have flashed the old image and the new one not installed correctly so reupload the image.

Official Rep

 • 

141 Messages

 • 

4.3K Points

5 m ago

Hi Bharat,

We do not recommend 9.0.00 code unless if it is a feature that you are looking for or, for or if  you need to use ICX 7850-48c.

Plus there will not be any further fixes.

The max you can go to is 8095d.

Please keep this in mind for future reference.

Bets Regards

Thanks

Hashim

20 Messages

 • 

344 Points

@hashim_bharoocha Are you saying that there won't be any further releases of the 9.x series?

Official Rep

 • 

141 Messages

 • 

4.3K Points

Hi Kevin,

We will have 9.0.1.0, but 9.0.00 will just not have any future fixes.

Also we need to backup config in case you decide to go with 9.0.00 as we cannot convert 9.0.00 to 8095 format. S please back up the 8095x config before you upgrade in case you need to back off to 8095x.

Hope this helps.

Thanks

Hashim

30 Messages

 • 

516 Points

@hashim_bharoocha looks like 9.0.00a was released as an update to 9.0.00 since this post with bug fixes. Have things changed or was that release a one-time 9.0.00 train update before 9.0.10? 

Important Announcement