Skip to main content

8 Messages

 • 

194 Points

Tue, Mar 26, 2019 10:05 AM

Answered

Response [500] Causes - SmartZone API

Been playing with the API and currently struggling to create a new WLAN. 

I am following http://docs.ruckuswireless.com/smartzone/3.6.2/sz100-public-api-reference-guide-3-6-2.html this documentation. 

Can generate invalid, 404 and 500 responses but never 201. 

Got everything structured correctly to generate as per the documentation but getting Response 500. Which is "The request is valid, but the controller is unable to process the request."

Is there a list of possible causes for ?

Could it be that we currently have a node out of service on the cluster?

Responses

Employee

 • 

305 Messages

 • 

4.9K Points

2 years ago

Hi Gareth,

So first are you using the correct user to access the API? use the admin user to make sure you have the correct rights.

Then what port are you using 7443 or 8443 as they have different URL's

500 is usually not authorised.

regards
martin
 

8 Messages

 • 

194 Points

2 years ago

Hi Martin,

If it was the port none of my requests would work but using 8443 as it is the recommended.

Tested with both an account with full rights and the inbuilt admin account. 

Also there are 2 codes for that:

401UnauthorizedAuthentication failed or you do not have the permission to perform the requested operation.

403ForbiddenAccess denied.

So why would it be returning 500?

8 Messages

 • 

194 Points

2 years ago

Solved, the posted data was malformed so should have been getting a 400 error code.