Skip to main content

Wed, Jul 17, 2019 11:33 PM

Answered

How to upgrade Apache Spark v2.2.0 to 2.4.3

current version of sci is running on centos running apache v2.2. I would like to know how to upgrade apache spark2.4.3

Here's the current system info:

NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/";
BUG_REPORT_URL="https://bugs.centos.org/";

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

[email protected] ~ #


Responses

43 Messages

 • 

780 Points

a year ago

Hi RS,

Unfortunately, you will not be able to upgrade Spark individually due to dependencies on other components.

We regularly update the software components within SCI, so the best thing for you to do is to always upgrade to the latest SCI version :-)

Thanks!
See Ho

9 Messages

 • 

190 Points

a year ago

We are on the latest version. There’s security issues/concerns on the Apache version. When can we expect this fix?

43 Messages

 • 

780 Points

a year ago

Hi RS,

We are constantly monitoring the security vulnerabilities in the various software components in SCI, and striking a balance between updates and compatibility/stability.

In the meantime, as recommended in the installation guide, please put the SCI VM behind a firewall with only the necessary ports opened (see installation guide for more details).

Thanks!
See Ho