Skip to main content

5 Messages

 • 

132 Points

Mon, Jan 9, 2017 11:22 PM

Sonos Play 5

I have 2 R500 Unleashed AP, the Sonos Play 5 stops playing after a few minutes. How can I fix this? I have look in the settings, but can’t find it.

 

Responses

Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

4 years ago

Don't know your network, but advice says to use Standard Mode if you have any wireless Mesh, and Boost mode only if all devices are Wired.

Champion

 • 

556 Messages

 • 

10.5K Points

I've got a full fledged Sonos setup, my comments:

If you are using ANY sort of auto-channel-switching on 2.4GHz, don't do it. Sonos's mesh networking can't deal with channel changes at all. Feel free to leave it on for 5GHz, but set up a static channel plan for 2.4GHz.

Or... If you can use a dedicated SonosNet (they call it BOOST or BRIDGE), I would recommend that if you have more than 1 Sonos speaker. This will let Sonos set up its own semi-proprietary 2.4GHz network which all the speakers mesh with. I find that this is more reliable especially if you have multiple speakers, as they do some magic sauce with realtime speaker synchronization and you don't deal with competing wifi traffic.

A dedicated SonosNet is set up by either wiring in one of your speakers, or wiring in a Sonos BOOST/BRIDGE device and then all your speakers can be wireless.

5 Messages

 • 

132 Points

Thank u very much John, going to setup a static channel.

2 Messages

 • 

70 Points

3 years ago

If you want to fix the SONOS systems on Ruckus you need to disable qos on the ethernet interface. I had this issue with my system. 

You need to go to the CLI and enter these commands however the last one is what fixes it. If you have a ZoneDirector you still need to login to the AP directly and issue the commands. Issuing the command on the ZD CLI does not work.
 
1.) rkscli: set qos directed multicast disabled
Directed Multicast ingress packet processing is Disabled   
on interface eth0
OK


2.) rkscli: set qos eth0 igmp disable
IGMP Snooping is Disabled on interface eth0
OK


3.) rkscli: set qos eth0 classification disable
QOS processing is Disabled on interface eth0
OK

(Set the correct Ethernet port) This means that if you have your cable plugged into eth1 then issue this command on that interface.

Reboot all of your SONOS systems and you should be enjoying your music.

Joseph