sander_groen's profile

57 Messages

 • 

800 Points

Mon, May 10, 2021 3:19 PM

Sonos and Ruckus unleashed

Sonos and Ruckus unleashed

There are many forum posts regarding issue's with Ruckus AP's and the use of Sonos wireless speakers.

I have been using Ruckus AP's professionally as well as personally for many years now.

Over the past few days I have been trying to figure out what is the best way to make the Sonos speakers work wirelessly when using Ruckus AP’s. My test setup consists of 1 x R710 and 2 x R610. One AP per floor. The unleashed version used is 200.9.10.4.233.

The main issue when using Ruckus AP’s and Sonos speakers is directed multicast.  This setting is turned on by default on the WLAN and ethernet interface.  I also noticed that if you are using more then 1 AP, things might not work in a consistent manner when your Sonos speakers are connected to different AP’s. Also note that even though your individual Sonos speakers work fine you will run into an issue  when you start using them in a 3.1 or 5.1 surround setup. (Mine were working fine until I added 2 Sonos One’s as surround speakers to my beam soundbar. The process of adding them via the Sonos S2 app failed. (Using my ISP modems Wi-Fi it worked on the first try). A non-working setup will show up in the Sonos S2 app under system as Name_of_room +?+? where it should be called Name_of_room +LS+RS.

Because of these issue’s there are 3 considerations. First, directed multicast needs to be disabled on both the WLAN as well as the ethernet interface. Second, if you have more than 1 AP, it has my recommendation to create a wireless network just for the Sonos speakers and have this network broadcast only on 1 AP that is closest to the Sonos speakers. This means you will need to work with AP groups. If you go this route make sure to remove the old wireless network from the Sonos S2 app otherwise, in my experience, the Sonos speaker can connect to the old and new wireless network which might give unexpected results. Also make sure that this newly created wireless network is in the same physical network as the clients that will be using the Sonos speakers. (Same VLAN for example). The third consideration is to disable the 802.11r FT Roaming setting on your wi-fi/SSID. When this setting is enabled I had an issue to add Sonos speakers via the Sonos S2 app. (After the sonos speakers are added successfully the 802.11r FT Roaming setting can be enabled again).

To disable directed multicast on the AP and have these settings maintained even after a restart of the AP, connect to the master AP via SSH. (A lot of forum posts issue the following command to fix the issue but they are not maintained after a restart of the AP: set qos eth0 directed multicast disabled).

(I use putty to establish a SSH connection). Once you are connected, login to the AP and issue the following commands:

(Please note that I used the r610 AP and R710 in my example. The model choices currently are: r510,m510,e510,h510,h320,r710,t710,t710s,r720,r610,t610,t610s,t310d,t310s,t310n,t310c,r320,c110,r750,r650,t750,r550,t750se,r850)

en

config

wlan "name of your wifi"

no qos directed-multicast

(The above command will disable directed multicast on the wlan interfaces.)

qos directed-threshold 0

end

ap-group System Default

model r610 port-setting

no lan 1 qos directed-mcast

no lan 2 qos directed-mcast

(Depending on the AP model, the above line might not be needed)

end

model r710 port-setting

no lan 1 qos directed-mcast

no lan 2 qos directed-mcast

(Depending on the AP model, the above line might not be needed)

end

end

end

I hope this forum post will help others in making their Sonos speakers work without any issue’s. Perhaps I will make a new post regarding Sonos speakers and Ruckus AP’s controlled by a zonedirector controller.

Responses

Official Rep

 • 

1.1K Messages

 • 

15K Points

1 m ago

Hi Sander,

We appreciate your effort on posting this with all your observations!

I hope others will find this useful.

And yes, directed multicast can be an issue with Sonos and other devices/services which relies on multicast, so its always best to adjust WLAN settings as per your device requirements.

Regards,

Syamantak Omer

35 Messages

 • 

728 Points

1 m ago

This is super helpful of you - I struggled to get Sonos working reliably a few months ago and gave up. Since I'm running a ZoneDirector I'd love it if you posted the follow-up you're considering.

57 Messages

 • 

800 Points

@anthony_rielly I will do another test with the ZD1200 and make a post on this forum. Most likely after unleashed 200.10 is released. (That will hopefully be within a month or so). I believe the guideline for a zonedirector is pretty much the same.

(edited)

11 Messages

 • 

172 Points

1 m ago

I discovered a bug in 200.9.10.4.212 and 200.9.10.4.233 that causes my R650 to not apply these settings across a reboot. I have to SSH into the AP and just re-save my WLAN (no changes required—just save it with wlan "WiFi Name" + end) to actually disable directed multicast after a reboot of my AP:

https://forums.ruckuswireless.com/conversations/ruckus-unleashed/how-to-make-no-qos-directedmulticast-persist-across-reboots/6073da6d9b965348de8d954e?commentId=6075a8cf6925f22ef568695e

I've since worked around this issue by wiring one of my speakers directly to my switch, making my Sonos system bypass the R650 with its own SonosNet.

Not sure under what circumstances this bug manifests itself but at least one other user confirmed they have the same problem. I noticed there is a new 200.9.10.4.243 update showing. I apparently cannot open a bug report without a support contract (I do not have one) so hopefully this gets picked up and fixed at some point.

(edited)

57 Messages

 • 

800 Points

@derek_fong Hi, a valid workaround is of course to wire one of the Sonos speakers to create its own wireless mesh network. I really wanted to avoid that. I also upgraded to unleashed version 200.9.10.4.243 today and everything still seems to be working fine in my setup.

37 Messages

 • 

582 Points

1 m ago

I have been using Ruckus and Sonos for a long time...

I standby the thing I have always said about Sonos... ONLY WIRE ONE AND MAKE THEM MESH!

Hundreds of installs, this has solved all sort of odd issues. Yes sometimes you need to put in a few boosts or place your speakers appropriately... but it immediately removes the problems of STP or Directed MultiCasts. Or switch ports shutting down.

Last step... set the channel on the Sonos Mesh to a specific channel and just tell your WAPS NOT TO USE THAT CHANNEL. I had to reboot my home system for cause 2 times in almost a decade.... house full of Play5/S5s Soundbars and Subs. My living room has an ARC+Sub+(2)S3s.

My boost is in the basement right on top of my rack.

(edited)

11 Messages

 • 

172 Points

I don't disagree with the advice to run one's Sonos system over SonosNet but the issue remains that this is a bug that Ruckus needs to fix. It affects more than just Sonos speakers—for example, printing over AirPrint does not work reliably (if at all) following a reboot of the AP, until I ssh in and re-save the WLAN configuration.

37 Messages

 • 

582 Points

The other thing about Sonos radios... they are B/N when they join your WiFi and they run at the ABSOLUTE SLOWEST data rate.

Keep them off your WiFi entirely...  And just give up that channel as it's gonna crawl.

37 Messages

 • 

582 Points

@derek_fong I found that problem with the printer was fixed by hardwiring the printers. Saw  it across a lot of brands of printers and multiple wireless vendors (NOT JUST RUCKUS). Made it policy to wire the printers... trouble calls stopped.

11 Messages

 • 

172 Points

@chris_nicholson_7159398 my printer is already hardwired to my Raspberry Pi which provides AirPrint support to my iOS/macOS users. AirPrint works fine with my UniFi setups and with Ruckus… AFTER I manually re-save my WLAN configuration following an AP reboot.

57 Messages

 • 

800 Points

Printers sometimes have an issue with the 802.11r FT Roaming setting. Sometimes it's better to leave it off.

Important Announcement