Skip to main content

16 Messages

 • 

280 Points

Fri, Nov 20, 2020 9:14 PM

Sonos and R550 unleashed

I have recently replaced my R510 with an R550, I did connect the new R550 so the config could be transferred before I disconnected the R510.

Now my Sonos-Players need a couple of hours until all of them can be seen in the apps. Restarting Sonos players does not help. On some devices they are faster, on some slower. When the Sonos devices are unavailable in the app, i can see the IPs of some devices as "connected" in the unleashed system. If I restart a Sonos which is not connected it does not connected, it  does not connect after ther restart either. If the sonos are finally connected, after every restart of the AP the problem is back. 

If I reset the R510 and bring it back online, then switch the R550 off, everything works smooth. 

I am aware what Ruckus recommends https://support.ruckuswireless.com/articles/000006140

However this setting doesn't seem to be necessary in my case on the R510 and does not fix the problem on the R550

Responses

Employee

 • 

603 Messages

 • 

10K Points

6 days ago

Hi Beni,

Could you check the WLAN configuration from the CLI when R550 is connected.

Check and make sure directed-multicast is disabled and directed-threshold is set to 0.

You can also check this information on AP's support logs.

Regards,

Syamantak Omer

148 Messages

 • 

2.6K Points

5 days ago

I would check 2 things:

1. Physical level. R550 support new standards, and in some configuration older (802.11n) clients can't be connected to wif6 AP (802.11ax).   Check that most compatibel mode is configured. Take into account that R510 is 802.11ac AP, so it had not such settings. I don't have Unleashed R550 handy, so can't check how configuration looks (we don't use Unleashed at all, just vSZ). Disable any advanced limiting features. Try to ping speaker which connected to WiFi network -- if it isn't answeringe, than connection isn't completed. If you can ping it, but it still doesn't connect  to otherSonos devices, than problem is on network level -- most probably some protocols or ports are blocked.

2. Check that you don't have some type of client isolation or L2 filtering on. Sonos and similar devices use weird ways of communication, so disabling something may have unpredictable results. Disable ARP proxy and directed multicast, disable any filtering and rate limiting and try again.

We had no problems with R550 so far, but we don't use unleashed and we don't use Sonos, so it means nothing.

16 Messages

 • 

280 Points

5 days ago

Thanks for your answers, I appreciate that you think about my issue. I have set the directed multicasting and the qos threshold according to this article now (you can see my config below): https://support.ruckuswireless.com/articles/000006140
In general, I have reset my APs after having this issue. I completely reconfigured them, doing only the minimal settings. (so ACLs, L2 filtering etc. is off)
I have set the two APs in two AP groups, so I can rapidly assign the SSID to one or the other AP. This should guarantee me that the settings are identical. My issue persists. After a reboot I can see the APs connected in the unleashed system, but I can not ping them (not from a PC and not from the unleashed system).When Troubleshooting one of the Sonos devices with the Troublesooting Tool under clients I can see that they finish the 4-Way Handshake but then do not request a DHCP address (which is fine if their lease is still valid). I am thinking about a remote wireshark radio capture of this SSID but I don't really know what to look for.

(edited)

16 Messages

 • 

280 Points

WLAN Service:
  ID:
    2:
      NAME = (hidden, contains a space but no special characters)
      Tx. Rate of Management Frame(2.4GHz) = 2.0Mbps
      Tx. Rate of Management Frame(5GHz)   = 6.0Mbps
      Beacon Interval = 100ms
      SSID = Sektor D30
      Description = Sektor D30
      Type = Standard Usage
      Authentication = open
      Encryption = wpa23-mixed
      Algorithm = aes
      PSK Passphrase = (hidden, no special characters)
      SAE Passphrase = (hidden, no special characters)
      SAE anti-clogging-threshold = 5
      FT Roaming = Disabled
      802.11k Neighbor report = Disabled
      Web Authentication = Disabled
      Authentication Server = Disabled
      Called-Station-Id type = wlan-bssid
      Tunnel Mode = Disabled
      Background Scanning = Enabled
      Max. Clients = 100
      Isolation per AP = Disabled
      Isolation across AP = Disabled
      Zero-IT Activation = Disabled
      Priority = High
      Load Balancing = Disabled
      Band Balancing = Disabled
      Dynamic PSK = Disabled
      Rate Limiting Uplink = Disabled
      PerSSID Rate Limiting Uplink = 0
      Rate Limiting Downlink = Disabled
      PerSSID Rate Limiting Downlink = 0
      Auto-Proxy configuration:
        Status = Disabled
      Inactivity Timeout:
          Status = Enabled
          Timeout = 1 Minutes
      VLAN-ID = 1
      Dynamic VLAN = Disabled
      Closed System = Disabled
      Https Redirection = Disabled
      OFDM-Only State = Disabled
      Multicast Filter State = Disabled
      Directed Multicast= Disabled
      802.11d State = Enabled
      Force DHCP State = Disabled
      Force DHCP Timeout = 10
      DHCP Option82:
          Status = Disabled
          Option82 sub-Option1 = Disabled
          Option82 sub-Option2 = Disabled
          Option82 sub-Option150 = Disabled
          Option82 sub-Option151 = Disabled
      Ignore unauthorized client statistic = Disabled
      STA Info Extraction State = Enabled
      BSS Minrate = Disabled
      DTIM period = 1
      Directed MC/BC Threshold = 0
      Call Admission Control State = Disabled
      PMK Cache Timeout= 720 minutes
      PMK Cache for Reconnect= Enabled
      NAS-ID Type= wlan-bssid
      Roaming Acct-Interim-Update= Disabled
      PAP Message Authenticator = Enabled
      Send EAP-Failure = Disabled
      L2/MAC = No ACLS
      L3/L4/IP Address = No ACLS
      L3/L4/IPv6 Address = No ACLS
      Precedence = Default
      Proxy ARP = Disabled
      Device Policy = No ACLS
      Vlan Pool = No Pools
      Role based Access Control Policy = Disabled
      SmartRoam = Disabled  Roam-factor = 1
      White List = No ACLS
      URL Filtering = Disabled
      Application Recognition & Control = Disabled
      Apply ARC Policy = NO POLICY
      WIFICalling Enabled= Disabled
      WIFICalling Profile= 0
      Client Flow Data Logging = Disabled
      Wlan Bind = all
      Client Connection Data = Disabled
      Transient Client Management = Disabled
      80211w-pmf = Optional

Employee

 • 

603 Messages

 • 

10K Points

Hi Beni,

Directed-multicast directed-threshold config look fine.

"I am thinking about a remote wireshark radio capture of this SSID but I don't really know what to look for."

For the service discovery, Sonos must me using mDNS protocol. Take a capture on source and destination devices including the AP and see if traffic is showing on both sides.

Regards,

Syamantak Omer

16 Messages

 • 

280 Points

Hi syamantak_omer, 

I figured out that I have the same issue (client is displayed as connected but unreachable after ap reboot) with my printer. It is easier to solve this problem first and then have a look at the multicast-issue with the sonos. I also figured out how to capture in the air with my WlanPi and Wireshark.

Which information could I share with you so you could have a look at? In the attachment you can see the output from Troubleshooting. The troubleshooting itself does not repair the connection

(edited)

Employee

 • 

603 Messages

 • 

10K Points

Hi Beni,

Unleashed troubleshooting utility will help you to find at what point client is failing but it can't fix it.

You have to check the OTA packet captures and look for more details in 4-way handshake message-1.

Try to connect this device to an open SSID and check if it connects or not.

If this is a general issue, all the devices should face this issue, but I think only specific device has the problem in your case.

If you are not sure what to look for, you can always open a support case and they will check the issue.

Regards,

Syamantak Omer