Skip to main content
B

5 Messages

 • 

60 Points

Mon, Nov 9, 2020 7:07 PM

R600 Unleashed Wifi Battery Drain

Hello, I've set up my first home network with nothing special regarding network rules, VLAN's, etc. The network seems to working great except the Wi-Fi seems to draining both my and my wife Pixel 3's. I've done a hard reset on my pixel and we've tested the Wi-Fi on different Wi-Fi networks and it seems the is coming from the R600 Unleashed AP. I actually have 3 of these AP's installed through the house, but deactivated the other 2 AP's to try and troubleshoot this issue. Any help would be greatly appreciated!

Network setup:

- pfSense 2.4.5-RELEASE-p1 

- EdgeSwitch 24 250Wv1.9.1

- R600 Unleashed 200.7.10.202.121

Responses

12 Messages

 • 

202 Points

17 days ago

I don't have a pixel, but I do have many other phones in the house using Ruckus AP's and have not seen this issue, so I can't help with that, but I did find this article regarding Pixel 3 battery issues.  Not sure if it will help or not, but certainly worth checking out.

https://www.androidcentral.com/some-google-pixel-3-phones-are-suffering-battery-swelling-issues

5 Messages

 • 

60 Points

Thanks, we're not experiencing battery swelling issues and we're not experiencing the battery drain issue when using Wi-Fi at different locations for the day.

Employee

 • 

603 Messages

 • 

10K Points

17 days ago

Hi,

Could you confirm if there are other Android devices facing this issue or just Pixel-3 phones.

Regards,

Syamantak Omer

Employee

 • 

603 Messages

 • 

10K Points

Also try to disable directed threshold on the WLAN, by running below commands on Master AP.

ruckus> 
ruckus>en 
ruckus#debug 
ruckus(debug)# remote_ap_cli -A "set directed-thr wlanX 0"
 
where wlanX is your service WLAN (wlanID). Run remote_ap_cli -A "get wlanlist" to find the WLAN ID.
-A is for executing this command in all connected APs. 

0 is for disabling directed threshold.
 
The above mentioned command will stop the Ruckus AP from converting the broadcast frames into unicast frames. 

To know more about directed threshold, refer the article from the below link.

https://support.ruckuswireless.com/articles/000002849

(edited)

Regards,

Syamantak Omer

5 Messages

 • 

60 Points

Thanks, I disabled the threshold on WLAN0 do I need to disable it on the other WLAN's too?

Employee

 • 

603 Messages

 • 

10K Points

You have only one WLAN "comet" and same is broadcasting on both the radio bands (2.4G and 5G).

Run the command for wlan32 as well.

Regards,

Syamantak Omer

5 Messages

 • 

60 Points

Thanks for the help so far and I'll test it today. Does this setup look correct now?

ruckus(debug)# remote_ap_cli -A "get qos wlan0"
---- Command 'rkscli -c "get qos wlan0 "' executed at d4:68:
Ruckus Wireless SmartMedia QOS info for wlan0 interface

QOS Configuration options:
Classification:               Enabled
UDP Heuristic Classification: Disabled
TOS Classification:           Enabled
Dot1p Classification:         Enabled
VID Voice Classification:
VID Video Classification:
VID  BE   Classification:
VID  BK   Classification:
Dot1p Classification VIDs:
Dot1p Marking VIDs:
Directed Multicast:           Enabled
IGMP Snooping Mode:           Enabled
MLD Snooping Mode:            Disabled
Static TOS marking:           Disabled (0x0)
Static Dot1p marking:         Disabled (0x0)

General      Mcast->U      Cloned     Filters    TOS-Mark
Stats               3           3       0/0/0    0/0/0/0

L2 Mcast      Packets     Unicast    Unk-Drop Known-Mcast
UDP Data            3           3           0         242

Heuristics      Voice       Video
UDP Packets         0           0

IGMP/MLD   Clone1/2/3
Errors          0/0/0

No Filters are currently defined on wlan0 interface
OK
---- Command Execution Summary:
         success: 1
         failure: 0
           total: 1
remote_ap_cli -A get qos wlan0
ruckus(debug)# remote_ap_cli -A "get qos wlan32"
---- Command 'rkscli -c "get qos wlan32 "' executed at d4:68:
Ruckus Wireless SmartMedia QOS info for wlan32 interface

QOS Configuration options:
Classification:               Enabled
UDP Heuristic Classification: Disabled
TOS Classification:           Enabled
Dot1p Classification:         Enabled
VID Voice Classification:
VID Video Classification:
VID  BE   Classification:
VID  BK   Classification:
Dot1p Classification VIDs:
Dot1p Marking VIDs:
Directed Multicast:           Enabled
IGMP Snooping Mode:           Enabled
MLD Snooping Mode:            Disabled
Static TOS marking:           Disabled (0x0)
Static Dot1p marking:         Disabled (0x0)

General      Mcast->U      Cloned     Filters    TOS-Mark
Stats               0           0       0/0/0    0/0/0/0

L2 Mcast      Packets     Unicast    Unk-Drop Known-Mcast
UDP Data            0           0           0         920

Heuristics      Voice       Video
UDP Packets         0           0

IGMP/MLD   Clone1/2/3
Errors          0/0/0

No Filters are currently defined on wlan32 interface
OK
---- Command Execution Summary:
         success: 1
         failure: 0
           total: 1
remote_ap_cli -A get qos wlan32
ruckus(debug)#

Employee

 • 

603 Messages

 • 

10K Points

Looks fine.

Let us know if this improve things. If not, we can tweak more settings.

Regards,

Syamantak Omer