Skip to main content

Sun, Aug 18, 2019 7:10 PM

Answered

Slow Download Speeds R710 Unleashed

Strange issue with R710 on latest unleashed firmware. Upload speeds consistently incredible on both laptop and phone but downloads even from 5 ft away never go over 200 but stay consistent through 3 thick walls. Speedflex on android shows 550 up 550 down to AP. Iperf reflects speedtest.net results. Cable shouldn't be the problem as I have plugged my laptop on it and gotten the gigabit fiber speeds I should be getting. I have factory reset it countless times set everything to auto and tried manually setting the bands and channel width, am I missing something? Any help would be appreciated.

Responses

2 Messages

 • 

94 Points

9 months ago

Tested with R510, iPhone 11 Pro Max, ISP 800mbps/200mbps

Standalone 104
597mbps/199mbps
Ping 8/ Jitter 1.2

Standalone 106
543mbps/199mbps
Ping 6/ Jitter 1.7

Unleashed 200.6
502mbps/199mbps
Ping 7/ Jitter 1.7

Unleashed 200.8
322mbps/195mbps
Ping 7/ Jitter 1.5

I've found that old firmware (104) gave me fastest speed but the ping was not stable, latest firmware will slow the top speed down massively, decided to stay in Standalone 106 and wait for the fix, 106 gave me the best performance with lower and stable ping.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

I shared your results with DE, thanks Darren.

2 Messages

 • 

94 Points

I retested today, here’s the result

Unleashed

Speedtest download/upload/ping/jitter

200.4 597/199/8/1.2

200.5 493/195/7/0.78

200.6 494/199/7/0.5

200.7 505/199/6/0.9

200.8 457/197/6/0.7

Speedtest Single connection

200.4 393/138/8/1.9

200.5 471/138/6/0.7

200.6 488/137/7/0.8

200.7 505/199/6/0.9

200.8 457/197/6/0.7

Ping low/avg/high

200.4 4.8/9.4/11.2

200.5 3.1/8.0/11.9

200.6 3.7/9.3/11.0

200.7 4.1/9.2/11.2

200.8 4.4/9.6/11.2

iperf3

200.4 214

200.5 237

200.6 245

200.7 228

200.8 221

 

I flashed R510 from 200.4, then used webpage upgrade option one-by-one from 200.5 to 200.6 to 200.7 to 200.8 in unleashed, it seems doesn’t impact much for latest firmware, but once I flash it directly to 200.7 or 200.8 fro local downloaded file, the Speedtest result will be below 300mbps, I dunno what’s wrong. I did manually select channel, and turned off background scanning for 5GHz to achieve stable result.

For now, I will stay in 200.6 as it gave me the most consistent result 

12 Messages

 • 

212 Points

9 months ago

hoping we can survive from coronavirus, and seeing the fix of ruckus firmware

otherwise firmware is no needed

14 Messages

 • 

372 Points

9 months ago

Michael,

My $80 replacements showed up yesterday, and now I'm averaging over 400 upload and download speeds without any range, bandwidth, jitter, or connectivity issues.  Two WAP's (with POE injectors), a POE powered cloud controller, and lifetime cloud management, for less than a single r510 (total investment $220).  

I truly appreciate your help on this, but I feel like the members of this forum have spent more time troubleshooting this bug than your Ruckus engineers.  I'll be closing my ticket with Mr. Sharma.  Please have him reach out to ANY other member of this forum, as I'm sure many would be glad to assist.  

Biggest takeaways:
-Jitter is a serious issue.  I was averaging 7ms with r510's, I'm seeing .5ms now
-Bandwidth Issue only exists on encrypted networks.  

As stated by the other users (who have WAY more experience than I do), I recommend you investigate chipset drivers or changes to the encryption algorithm since 200.6. 

All the best,
Rich M

Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

ACK and THX...

3 Messages

 • 

70 Points

So what was the equipment you got with the $80 replacement and the $220 investment?
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Mr Lee,

   Per our forums guidelines, we do not allow promotion of other company products nor recommending not to use our products.  That goes for your comment too EightOhTwoEleven...

178 Messages

 • 

2.9K Points

Then fix your product so we don't have to look elsewhere.

3 Messages

 • 

70 Points

Michael,

That's the problem, there was no mention of what was replaced or replaced by what. Could have been a product replacement ruckus sent and charged Rich $80 for or a possible issue at the modem/router which was replaced and resolved the issue.

Since Rich is telling you about his solution and it worked, thought was a solution you two came up with, but by your response, seem like Rich have given up.

Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

9 months ago

And our Engineering team is able to reproduce the issue(s) in their testing and are measuring different variables.
Feedback with results from all of your clients (mostly iOS) and encryption have been received.  We definitely do care
about performance of the Unleashed code, thru all APs, not just R710s.  I wish I had further information to share at
this time, but need to let you know this is an escalation in our system.

20 Messages

 • 

274 Points

9 months ago

I would like to say that though the focus is on iOS devices, the problem persists on Android as well. I've been through many calls with Ruckus and have been unable to fix my R510's. With 200.8, I am now experiencing frequent drops of my 5ghz channel forcing my devices to switch to 2.4. Even when the channel comes back online (I can see the light on the AP), my devices won't switch back without a restart. This happens on my Android phone, Apple Phone, Apple TV and Amazon Fire devices. 

Champion

 • 

556 Messages

 • 

10.5K Points

Hey Ryan, this sounds like a very different problem and it would be good to create another thread. If the AP is dropping the 5GHZ channel altogether, that is either a "target fail" event (sort of like a firmware crash), channel change, DFS event, or something along those lines. That's quite different from the discussion in this thread, where on both bands, the radio is up and stable but the observed throughput is much worse in the AP->client direction than the client->AP direction.

2 Messages

 • 

70 Points

9 months ago

Any updates on this? 

20 Messages

 • 

372 Points

9 months ago

Update: tried the latest unleashed firmware from earlier this year. The tenants demanded I purchase a new access point due to the latency and slow sleeds. Tested with iPerf running on my laptop and phone. Download speeds around 215mbps. Phone can get 400mbps normally with the ISP router/ap we used to have.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

9 months ago

Greetings,

    DE/QA have let me know [ER-7956] that they have found some things significant,
that appear to impact many of the issues. We are finalizing some fixes for further
evaluation, are seeing much closer UL/DL speeds across all the client devices under 
test, GalaxyS10, iPhone7/8/11 against Xiaomi10, iPad Pro, MacBook Pro, Win10.

  This is a preliminary update, that our attention to the issues are producing results.
Thanks to customers who've shared time to collect/share logs. The observed speeds
are much closer, and appear typically within 100-150mb apart at most. We hope to
have the improvements available in firmware maintenance releases soon.  I'll ask 
that they are included in Unleashed 200.8, and not just 200.9 and later. Thanks.



13 Messages

 • 

278 Points

ZoneDirector and/or standalone firmware updates would be nice too, thanks :).

178 Messages

 • 

2.9K Points

Add vSZ/SmartZone to that list as well.

10 Messages

 • 

372 Points

Please, please make sure they understand this impacts ZoneDirector as well.

10 Messages

 • 

372 Points

9 months ago

Just to add another data point here, I've been dealing with this issue since February 2019.
Here are some important highlights:


It appears to only impact download speeds on iOS devices. Upload is unimpacted. I can confirm 12.1.4 was OK with firmware 10.2.0.0.189. 24 hours ago, I was running speedtest with 450Mbs downloads and now downloads are 30Mbs on the same device running the same iOS in the same location on the same AP.


The firmware that works is 10.2.0.0 build 189. Everything after that shows the problem of slow downlink.


ZD on firmware version 10.2 build 189 with 4 AP's (R710), speed in Iphone download speed:500mbps. 
After upgrade the speed is download speed:95mbps, the issue is only with download speed and on Iphones. 
The wlan is wpa2(aes). 
no rate limit configured. 
upgrade to 10.3 build 398. 
Create a new open wlan and the devices are getting good speed 500mbps, however when we change the Encryption type to wpa2(aes) the speed again drops. 
Change the Encryption type to wpa2(TKIP+AES), still the same speed.


38 Messages

 • 

682 Points

Please do not flood the topic with information that is not true and unrelated to the topic. This is topic for Unleashed firmware and I can confirm 100% it affects also a lot of Android devices!

178 Messages

 • 

2.9K Points

So don't flood with unrelated information, oh yea, here is my unrelated information. Gotcha.

10 Messages

 • 

372 Points

Flooding the topic?  I've made two posts and I've said that it "appears to only impact download speeds on iOS devices..."  That was from February 2019, as I said.

And, it is absolutely related to the topic.  It's the same AP and it impacts ZoneDirector APs in the same way that it impacts Unleashed APs.

That's an important point for BOTH ZoneDirector AND Unleashed users and for the engineers to know about so that they can hopefully solve this issue.

Why don't you let the Ruckus engineers decided what is important and relevant before trying to artificially limit what information is posted in this thread.



Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Easy please, we are now on track with all device types, on all UNL/ZD/SZ firmware to improve encrypted WLAN bi-directional performance.
Unleashed brought issue(s) to light, but comparisons with other device types and Solo/ZD/SZ too helped find the problem(s).
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

9 months ago

Unleashed brought the issue(s) to light, but the fix(es) will be applied across Solo, ZD, and SZ platforms when finalized. 


Unleashed 200.7, 200.8, 200.9 will be the first maintenance releases.

10 Messages

 • 

372 Points

Thank you for letting us know that the fix will be implemented across the product portfolio.  That's all I wanted to know.

4 Messages

 • 

224 Points

Michael, thank you for the reassurance that this is being actively worked on and patched in 200.7, 8 and 9. Just curious, might you have any idea on an ETA? Thank you again for your accountability and transparency.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

The answer is 'not soon enough', possibly mid-June, which I wrote looked like we hadn't fixed our problem for months and we wanted it in Unleashed first 200.7/200.8 (other Solo/ZD/SZ fixes are included). Our Lennar Ruckus at Home customers are deployed with 200.8 (still).

10 Messages

 • 

372 Points

Michael: can you say the version number of the ZoneDirector software where the fix will appear? And will the ZD version appear at the same time as the Unleashed version?

Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Version build number (the last digits) are the last thing decided before Release Notes are put together.I do not have the ETA for Solo/ZD/SZ updates yet.

16 Messages

 • 

252 Points

8 months ago

Hi guys,
What is the current situation, when will the problem finally be solved? Greetings Mike

10 Messages

 • 

372 Points

8 months ago

Looks like ZoneDirector 10.4.0.0.98 software was released yesterday.  It contains this note in release documentation:

Resolved an issue with throughput performance in WPA/WAP2 WLANs. [ER-7956]

I'm not as familiar with the unleashed software, but I would imagine they're very closely related.  That said, I do not see an Unleashed update on the site that would correspond to this.

I have not yet updated and wondered if any one else has...


178 Messages

 • 

2.9K Points

What's a WAP2 WLAN?

368 Messages

 • 

4.8K Points

it’s a type o ...I think it’s meant to be WPA2 WLAN
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

8 months ago

ZoneDirector Refreshes have been posted, and Unleashed 200.8 is based on ZD 10.3 code (10.4 will be base for Unleashed 200.9 around Nov2020).
I have received confirmation from DE manager that we will have the ER-7956 iOS device performance fix in Unleashed 200.8 update by tomorrow (Friday US).  
I'll be busy posting the AP images all day, look for your model(s).

38 Messages

 • 

682 Points

what about 200.7 fix ?
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Yes, right behind, based on ZD 10.2.1.0.183 (MR1 Refresh5).

40 Messages

 • 

580 Points

Michael, what I'm curious about is what actually caused the issue and how it was resolved. Could you please elaborate?

33 Messages

 • 

536 Points

Hi Michael,

in typical Ruckus fashion, nothing ever happened.  No fix, just promises. I spoke to 2 engineers and they tried to trouble shoot the issue. After about 2 hours, I got so fed up with them that I refused to waste any more time. I am appalled that they don’t replicate this issue in their own lab but instead have customers troubleshoot for months on end. To be honest, we’ve had very bad luck with Ruckus and will not install it at any customers site any more. Nothing but complaints. Especially with MAC and SONOS products. Stay away!!!  


Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Hello Michiel,

   What platform (Unleashed, ZD, SZ, Solo) are you testing, with which model APs
and WLAN settings?  We just released ZD updates with iOS performance improvement
(aka ER-7956) that will appear in Unleashed (200.8 tomorrow, 200.7 soon). 

    There are acknowledged/published issues with MacOS, with a version recommendation
in a recent KBA-10544 if having MAC specific issues.
https://support.ruckuswireless.com/articles/000010544  

    I see two knowledge base articles related to Sonos settings and directed multicast feature.https://support.ruckuswireless.com/articles/000006140 https://support.ruckuswireless.com/articles/000004138

20 Messages

 • 

372 Points

8 months ago

iOS improvements... Strange way of putting it, does that mean the WPA2 issues are resolved, or is this literally optimizing for mobile Apple devices? Sorry for those who notice with iPhones, I notice with everything that the download speeds are much slower than upload.

10 Messages

 • 

250 Points

Exactly; it's annoying that this problem keeps being referred to as being Apple-exclusive. All my clients (laptops and phones; none of them Apple) are affected by this on 200.7 and 200.8, and as soon as I downgrade to 200.6 throughput doubles.

4 Messages

 • 

224 Points

I have to pile on here as well. This issue has clearly been demonstrated to effect more client types than just iOS/iPhone. As one example, I'm seeing the same speed limitations on my own Samsung Galaxy Note 5 (Android 8, all updates), when connected to a WPA2 network running on the R510, 710 and 720 (Unleashed 200.8.10.3.243). No such speed issues with the 510 and 710 on 200.5.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Yes, all WPA2 encrypted WLANs got affected by a "fix" we made around a Security Bulletin at Christmas.
All platforms will be updated soon with the "revert performance but closed security hole" maintenance releases.

I haven't seen the release notes yet, so this is not "official" until later today, but here is a link to the first image,
an MD5 checksum'd 200.8.10.3.278 (GA Refresh) R710, the AP first reported on this thread:

https://support.ruckuswireless.com/software/2504-ruckus-unleashed-ap-200-8-10-3-278-ga-refresh-softw...
Get it now, as I have to "hide/unpublish" until I have all images uploaded and approved RNs, thanks.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

This preliminary link (has old Release Notes) is for Ruckus at Home (Lennar) R510 model APs:
https://support.ruckuswireless.com/software/2516-ruckus-unleashed-ap-200-8-10-3-278-ga-refresh-softw...

I'm staging 20 AP images and SNMP MIBs, still waiting for finalized 200.8 GA Refresh Release Notes.

368 Messages

 • 

4.8K Points

So far so good for the R710s, Performance seems as good as 200.6.10.1.312. When testing with iperf3

16 Messages

 • 

394 Points

8 months ago

Michael, can you please give a link to the R610 as well. I would like to test asap.