Skip to main content

Wed, Sep 18, 2013 1:05 AM

Answered

Management Vlan Config - 7372

I am trying to configure a 7372 with a static ip and on managment vlan 4. I can configure 7982's just fine but the 7372's do not work.

As soon as I change the management vlan on eth0 to vlan 4 I can no longer communicate with the AP at all. The cisco switch port it is plugged in to is a trunk port and the ZD is also on port 4. As I mentioned that the 7982's work fine like this. I have tried everything but no config works once I change the management vlan.

As I deal with networks daily I am quite confident in the subject matter of trunks and vlans, I just cannot understand why only the 7372's do this for me.

Order of steps
1. change port type to trunk
2. statically assign ip information for vlan 4 network (reconnect to web ui)
3. change management vlan to 4 (lose all connection)

Responses

1 Message

 • 

62 Points

7 years ago

Hi,

Try following commands on ZF7372

The interface command is used to set parameters for the wireless and Ethernet
interfaces. These parameters include VLAN, port type (for Ethernet ports), 802.1X
settings and port forwarding method

you must first use the get/set interface command to ensure that the interface will be able to handle the newly assigned VLAN.

set interface [forward ] type untag {|none}
[vlans

Example :

rkscli: set interface eth1 type vlan-trunk untag none

The above command is to set the ip address in multiple ways (static, DHCP or PPPoE),
and configure IP settings if set to static. Additionally, you can use the VLAN argument to set VLAN assignment for the interface. We can configure each of the interfaces separately, as we are setting the LAN for an interface

set ipaddr {wan|video|mgmt|l2tp} [vlan ] {options}

Example :

rkscli: set ipaddr wan 192.168.0.1 255.255.255.0 192.168.0.1

I hope this is helpful

5 Messages

 • 

172 Points

7 years ago

I haven't seen this exact problem, however I (briefly) considered using a separate management vlan until I realised I would have to plug each AP straight into the ZoneDirector to get it provisioned and configured with the management vlan, or configure the vlan at CLI before it could be installed at a site (which is normally done by the box-shifters in my organisation).

So rather than do that, I leave the switchport configured as a trunk but with a native vlan. This way, the AP can be plugged in straight from the factory (it will not tag it's own traffic by default), however the switch will see this and tag with your management vlan. The ZoneDirector gui is configured to use vlan 1 (ie untagged) for managaement, but this is handled by the switch by putting the ZD as an access port in the management vlan.

Eg:

interface FastEthernet0/1
description *** Ruckus AP ***
switchport trunk encapsulation dot1q
switchport trunk native vlan
switchport mode trunk
no cdp enable
spanning-tree portfast
end
!
interface FastEthernet0/24
description *** ZoneDirector ***
switchport mode access
switchport access vlan
speed 100
duplex full
no cdp enable
spanning-tree portfast
end

Regards,
Stuart

3 Messages

 • 

130 Points

7 years ago

Thanks for the suggestions. I have tried Moji's idea and configured the ap from the cli and once again this left me with no access to the AP.

Stupots, I have tested your idea in our lab environment but it will not work with our configuration. Our ZD is on a trunk port but configured for vlan 4 management and must remain that way to communicate with all other AP's we have. This is simply a 7372 problem and I want to fix that rather then muck with the rest of the network infrastructure.

This is quite frustrating as the AP simply will not communicate once you switch the management vlan to vlan 4. I can't be the first person to try and configure a 7372 this way so hopefully someone has the answer. The AP does not behave like the 7982.

4 Messages

 • 

122 Points

7 years ago

I have seen the same problem in most deployments, when I tried to tag the management VLAN the communication between the access points and the controller was lost (I have worked mostly with ZF7363 and ZD1100). Last time I was able to restablish the communication by switching the native VLAN of the trunk ports. In my desesperation to get the network up I switched to native VLAN from its default ID of 1 (I was working on a Catalyst 2960) to the ID I was using for the manegement VLAN 2327, then when I switched back the native VLAN back to ID 1, magically the ZD started to communicate with the APs using VLAN 2327. I am aware that this doesn't make sense and I'm still trying to figure out what happened that day. Maybe someone has some ideas?

PD: The trunk port was configured to allow all VLAN traffic.

3 Messages

 • 

130 Points

7 years ago

I fought with this for a long time. Finally I left the management vlan alone and connected the AP to the ZD on it's local vlan. Once connected to the ZD I would set the managment vlan on the AP through the ZD AP config page and it works fine.

Might work for you.

4 Messages

 • 

122 Points

7 years ago

Yes, thats a viable solution but in large deplyments you would be doing this process for each AP spending a lot of time and resources.

4 Messages

 • 

122 Points

7 years ago

I have the solution kindly given to me by Ruckus Personnel: Since the AP doesn't know ehich VLAN it has to use for management one has to configure this parameter manually on the AP interface. For example for ZF7363, on the GUI, first on "ethernet ports" you have to configure the port that it will connect to the network as "trunk". Then on "Internet" you look for the "management vlan" field and there you specify the ID you have previously configured on the ZD and voula! the AP integrates with the controller!

1 Message

 • 

50 Points

7 years ago

That's exactly what we tried and it fails every time for any 7372. Works fine on our 7982's.