Skip to main content

Tue, Feb 19, 2019 3:29 PM

Answered

How i can modify AP Heartbeat?

Hi Guys,
 i need to modify the Access Point heartbeat, where i can find this fieldin the controller?

Responses

174 Messages

 • 

4.8K Points

2 years ago

Hi Enrico,

This option is not configurable via the SZ GUI or CLI but can be modified in the AP directly using the set scg command:

-> {config|heartbeat} interval . 30-300.


rkscli: set scg heartbeat interval 60
OK

This is verified by the get scg command

rkscli: get scg

------ SCG Information ------
SCG Service is enabled.
AP is managed by SCG.
State: CONNECTED
Server List: 12.111.80.197,10.1.4.11
SSH tunnel connected to 12.111.80.197
Failover List: Not found
Failover Max Retry: 2
DHCP Opt43 Code: 6
Server List from DHCP (Opt43/Opt52): Not found
SCG default URL: RuckusController
SCG config|heartbeat intervals: 300|30
SCG gwloss|serverloss timeouts: 1800|7200
-----------------------------
OK

Note the default value is 30 seconds which is also the minimum value.

Also note - by increasing this value you will delay the time it takes for an AP to move to a new node in a multi node cluster as the heartbeat loss is used to determine if the AP can still connect to the SZ.

It is possible to configure this option on all AP's in a Zone by using the SZ Diagnostic Script > AP Script feature.  See this Knowledge article for details AP CLI scripts:

Execute AP CLI commands (for configuration options not available in SCG) into all the APs assigned to a zone
https://support.ruckuswireless.com/articles/000004057


Modifying the heartbeat time is also covered in Knowledge base article:

How to set AP heartbeat timer to vSCG or vSZ or SZ100? 

The article provides CLI command for changing AP heartbeats timer to vSCG or vSZ or SZ100
https://support.ruckuswireless.com/articles/000004971

I hope this information is helpful.

Thank you for choosing Ruckus Networks products.





3 Messages

 • 

84 Points

I have a ZD1200 with an R600 connected over WAN. I want to change the heartbeat value to something higher as i'm always seeing 'heartbeat loss' in the logs. I can SSH into the R600 but 'get scg' command just returns 'command is not recognized'. I need to display it's current value then i would like change it.

Any advise would be welcomed . . 

Employee

 • 

625 Messages

 • 

10.2K Points

Hi Craig,

Commands given by Albert are for vSZ/SZ managed APs, not ZD.

I dont think on ZD we can change the heartbeat timer.

ZoneDirector (ZD)  and connected Access Points (AP) expect heartbeat (echo) requests or responses in 40 and 30 seconds respectively. If not, ZD and AP would consider the heartbeat is lost.

ZD side

a.       After 2 consecutive (80 seconds) heartbeat losses, ZD raises a "heartbeat lost" alert.

b.      After another 20 minutes, if the AP does not discover and join ZD, ZD raises "Lost contact to AP" alert.

AP side

c.       After a heartbeat lost (30 seconds),  AP sends 12 consecutive heartbeat requests every 5 seconds (total 60 seconds).  If it still does not hear a response from ZD, AP enters Sole Run state and starts to send discovery request.

d.      In Sole Run state, AP sends out discovery request every 5 seconds for 15 minutes.  After receiving no responses, AP will reboot and leave a reboot reason viewable in support text stating "cannot discover ZD in 180 attempts".

Regards,
Syamantak Omer

Regards,

Syamantak Omer

3 Messages

 • 

84 Points

Thanks for that reply, and yes I understand that.

The exact issue I am having is that I have a few R600's all connecting to the ZD over WAN and I am receiving 'heartbeat lost' messages in the logs.

With devices connected using PSK it is fine always (no re-authenticating), but for windows devices connected using EAP the end users connection will be dropped requiring re-authentication at each 'heartbeat lost' event and PC restart.

Note: OS X, Android and iOS using EAP do not have to re-authenticate at each 'heartbeat loss' or device restart.

This 'heartbeat loss' was a major issue with my 'guest' SSID also but I found in the SSID's WLAN advanced settings an option called 'Grace Period' which I enabled and it seem's to have resolved the need to re-login constantly through captive portal.
 
There is no 'Grace Period' option on my 802.1x EAP SSID's advanced setting.

To be clear my internet connection is not dropping out ever, This issue seems to be only between the ruckus AP's at the WAN connection to the ZD.

Can you recommend anything I can do to improve the AP to ZD connectivity or reduce the sensitivity over WAN. Any help would be greatly appreciated in resolving this issue.

Just to be clear . . I'm not using RADIUS, IEEE 802.11x authenticates against the ZD's internal user database.

 

3 Messages

 • 

102 Points

2 years ago

Thanks