Skip to main content

10 Messages

 • 

170 Points

Mon, Jun 18, 2018 3:34 PM

Answered

Enabling multicast for a Sonos environment

I am having trouble with a ZoneFlex R510 in standalone mode, and integrating Sonos. In a nutshell, I can't get the Sonos hardware to join the 2.4Ghz network. Here is a relevant discussion on the Sonos forums. I spent hours troubleshooting this last weekend. When I put my old WAP in place everything worked fine. Re-introduce the Ruckus equipment and it falls apart again. It sounds like I need to try enabling multicast traffic?

https://en.community.sonos.com/troubleshooting-228999/surround-setup-error-6804042

Is this an option in the Web GUI or a CLI only thing? I started looking into this last night and did not find any clear steps. The AP is running v200.6.10.1.308 software.

Responses

10 Messages

 • 

170 Points

2 years ago

Nobody, eh? So I need to call support?

24 Messages

 • 

340 Points

24 Messages

 • 

340 Points

2 years ago

https://forums.ruckuswireless.com/ruckuswireless/topics/sonos-play-5

Last post will fix your issue providing you have no other networking issues

10 Messages

 • 

170 Points

2 years ago

Thanks for the post. The syntax of those commands is different for Unleashed? They did not work for me when I was connected to the AP via SSH.

Here is the translation. Or at least the commands that executed successfully for ME.

The first command was supposed to be this:

rkscli: set qos directed multicast disabled

Should be:

ruckus(config-wlan)# no qos directed-multicast

The second command was supposed to be this:

rkscli: set qos eth0 igmp disable

Should be:

ruckus(config-wlan)# no qos igmp-snooping

The third command I could not figure out.

rkscli: set qos eth0 classification disable

I tried digging into the system configuration and entering this command, which is the ONLY QoS setting I could find in the Unleashed CLI:

ruckus(config-sys)# no qos
Changes are saved!
System QoS function has been disabled

However, after entering this series of commands I am still not able to join my Sonos hardware to my Ruckus WiFi network. The error presented by the Sonos controller is to make sure the 2.4 Ghz WLAN is 802.11b/g compatible.

:/




2 Messages

 • 

90 Points

for this command - rkscli: set qos eth0 classification disable 
try running
no qos classification 

24 Messages

 • 

340 Points

2 years ago


You didn’t say it was unleashed. That is a controller so you won’t have those commands. What version unleashed? Also change the unleashed to a regular stand alone AP software and run those commands and it should work. Sonos doesn’t like enterprise networks that is why your other AP works. Hence the very reason you don't' use consumer products in business WLANs You can still get this to work. I will setup my unleashed and see what I can do. Stand by....  Also you may have to reset your wifi on the Sonos itself. I honesty think these things are garbage but I listen to them too LOL  :)

10 Messages

 • 

170 Points

2 years ago

I am currently running 200.6.10.1.308 of Unleashed. Seems silly to have to "downgrade" it to standalone mode. Is there no equivalent command or setting in Unleashed? I'd really like to figure this out, just in case I ever run into this situation again at a client site. I'm happy to switch to the ZoneFlex standalone mode for home, but in the enterprise that may not be an option.

;)

For the cost the Sonos stuff sounds OK, and the UI is pretty damn good. I like the PlayBar a lot.

My other AP is also an Enterprise-oriented solution. But I hear what you're saying. This system just seems especially persnickety.

24 Messages

 • 

340 Points

2 years ago

HI Eric

You may not be able to use this in a business I haven't looked lately at the unleashed however you can try this

if it is available

Radio Resource Management:Enable 802.11k Neighbor-list Report  (enable this)

and set this to this 

Directed MC/BC Threshold:  set this to 0

(0-128)Defines the client count at which an AP will stop converting group addressed data traffic to unicast  


do not allow background scanning and set the 2.4 to channel one only do not use the other 2.4 channels.

I use a ZD1200 and this gives me the availability to set those commands so in a business you may need to go this route

10 Messages

 • 

170 Points

2 years ago

I just re-flashed the AP so its a ZoneFlex AP. First command was not accepted:

rkscli: set qos directed multicast disabled
usage: set qos...
    set qos heuristics {voice|video} classify
         -- Sets octet count for Heuristic-based classification
    set qos heuristics {voice|video} noclassify
         -- Sets octet count for Heuristic-based no-classification window
    set qos heuristics {voice|video} {ipg|pktlen}
         -- Sets parameters for Heuristic-based classification
    set qos tos classify {voice|video} {|none}
         -- Sets values for TOS-based classification
    set qos tos mark {voice|video}
         -- Sets TOS values for each type of traffic
    set qos dot1p classify {voice|video} {|none}
         -- Sets values for DOT1P-based classification
    set qos dot1p mark {voice|video}
         -- Sets Dot1p values for each type of traffic
    -------------------------------------------------------------

The other two commands were accepted. And...it seems like Sonos is able to connect to the WLAN. I may try reverting back to Unleashed and seeing if the settings you outlined above are available.

Thanks for all the help. I appreciate it!


24 Messages

 • 

340 Points

Your welcome. I spent 4 days on this until I figured it out.

24 Messages

 • 

340 Points

2 years ago

Yep it works that way and on a zd. But it won’t work from the zd GUI controller. You still have to go to the AP and use the commands.

10 Messages

 • 

170 Points

2 years ago

Yep. These were issued while SSH'd into the AP.

24 Messages

 • 

340 Points

2 years ago

Yep that’s why it works. How did it go on flashing back to unleashed?

24 Messages

 • 

340 Points

2 years ago

Hi Eric
Just propped up a t300  Firmware: 200.6.10.1.312
It worked for me with these settings

Turn off all scanning and load balancing (make your AP as dumb as Sonos)

Set neighbor list report on the radio control setting in the WLAN Radio Resource Management: Enable 802.11k Neighbor-list Report

Make sure that there is only channel 1 available to Sonos

and lastly 802.11d:Support for 802.11d (only applies to radios configured to operate in 2.4 GHz band)

I am listening now..... Lol

Joseph

10 Messages

 • 

170 Points

2 years ago

There does not appear to be a way to both disable background scanning AND enabble 802.11k Neighbor-list Report. At least when I un-checked BackGround Scanning the option to check Radio Resource Mgt. was disabled (in WLAN > Advanced Options).

Where is the option to set the directed multicast threshold?

10 Messages

 • 

170 Points

2 years ago

Re) 802.11d support. Are you saying to disable it?

24 Messages

 • 

340 Points

2 years ago

Enable d
Enable k

Background scanning is in services section

24 Messages

 • 

340 Points

2 years ago

There isn’t a option for multicast threshold that is why unleashed is not a good fit for sonos