Skip to main content

3 Messages

 • 

100 Points

Tue, Jan 23, 2018 11:39 AM

Clients disconnection issue

Hi,

We have some issues about clients randomly disconnected from our Wifi.
It happens frequently without clear reason.
When they are disconnected, the can disconnect and reconnect to the network and it's working fine again.
Our Wlan is configured with WPA2/AES security.
No isolation, no captive portal.
We set the inactivity disconnection to 500minutes.
It's configured to provide a VLAN (33)

Our controller is a ZD1200
Firmware : 9.13.2.0 build 33
Our access points are R500

Do not hesitate if you need some more information.

Thank you for your help !

Matthieu

Responses

9 Messages

 • 

190 Points

3 years ago

had seen this issue with ZD3000 and stil having similar issue in Smartzone 100. Sent out multiple OTA captures . Issue still unresolved. All we see on the logs is "reason code 4" - client inactivity timeout and this is happening in IOS devices. Is yours issue the same? @Matthieu

3 Messages

 • 

100 Points

3 years ago

We have this issue especially on windows 7 computers.

For mac addresses that are disconnected, we can see this kind of logs :

STA-DISASSOC-REASON [ieee80211_input(),2097,received IEEE80211_FC0_SUBTYPE_DISASSOC] 10:08:b1:a0:9c:a1 rx_rssi=54,ack_rssi=0,reason=8,freq=2452,chan=9,rx pkt,byte;tx pkt,byte=(4712,1061152,75127,11654925).


I can't see some "reason code 4" - client inactivity timeout" in our logs.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

Your message, with reason=8, says the client left the AP WLAN.

9 Messages

 • 

190 Points

3 years ago

same problem here. Did multiple captures and sent support logs. All we get is reason code 4 as well. It really hard to replicate & customers complain different times of the day in diff location. Not possible to do the entire OTA capture with them.However managed to do OTA but still all Ruckus is saying is reason code 4 . Whats next? BTW this problem started in ZD3000 and still is present in our SZ100 with the latest code.

4 Messages

 • 

90 Points

3 years ago

Try setting qos directed threshhold to 70 and check  form controller. 
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

QOS directed threshold value does not go to 70!
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

...don't go over 5.

4 Messages

 • 

90 Points

ruckus>en
2)ruckus#config
3)ruckus(config)#wlan 'your wlan id'
The WLAN service 'your wlan id' has been loaded. To save the WLAN service, type 'end' or 'exit'.
4)ruckus(config-wlan)#

5)ruckus# qos directed-threshold 70

6)ruckus# exit ( type this to save the configuration)

3 Messages

 • 

100 Points

3 years ago

Hi, where we find this setting please ?
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

From KBA-2849:

Ruckus APs by default convert incoming broadcast and multicast traffic to unicast. This feature has the following benefits:
1. By default both broadcast and multicast traffic go out at a lower data rate over wireless. Converting them to unicast enables the AP to send the data at higher rates. This behavior conserves airtime.
2. It also enables 802.11 acknowledgements. Acknowledgement from a receiver ensures reliable data transfer.

This features is turned on each SSID until the client count reaches 5. This feature gets disabled automatically once a 6th client joins the SSID.

If you have incompatibility issues with any application due to unicast transmission, there are certain commands you can run to disable this behavior even before the client count crosses 5.

These commands need to be run from "wlan" context in ZD CLI.

1. ruckus(config-wlan)# no qos directed-multicast
Above command will disable directed multicast which means a multicast traffic will go out as multicast traffic.
This command has no impact on the directed broadcast behavior which remains enabled.

2. ruckus(config-wlan)# qos directed-threshold 0
This command disables BOTH directed broadcast and directed multicast on the SSID. If there is only a single client, it will receive broadcast traffic as broadcast and multicast traffic as multicast.

Please note that you can specify any number at the end of above line based on your need. For example, it can be 1, 2, 5, or 10,etc. But be careful with any number above 5 since it will have performance impact on the AP.




4 Messages

 • 

90 Points

Can you please let  me know what kind of performance issue will be there if i exceed above 5 or 10  or set it to 70?

4 Messages

 • 

94 Points

2 years ago

same issue we are facing in our environment client not disconnects from AP but unable to reach Internet even they are not able to ping Gateway , AP. ..? 

what are the troubleshooting steps for this issue.?
   
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

What version of code running on what kind of controller? 

How many of which model of APs? 

How many WLANs being broadcast?  What is authentication type on affected client WLAN?

How many clients on the APs?

Then describe network, from AP where clients can't ping the def-gw to your def-gw.

1 Message

 • 

60 Points

10 months ago

We have some issues about clients randomly disconnected from our Wifi.
It happens frequently without clear reason.
When they are disconnected, the can disconnect and reconnect to the network and it's working fine again.
ZD1200 & AP R510

4 Messages

 • 

90 Points

10 months ago

Is it happening with all operating system? or any particular devices?

2 Messages

 • 

70 Points

5 months ago

Did anyone here experiencing this issue find a resolution? We’ve been having clients randomly losing network/internet connectivity also. Client appears to still be connected to AP, although suddenly loses network, can’t ping gateway etc.

We’re running vsz-e controller majority r750 and r710 APs.

Also had a support case open with Ruckus for months with no resolution, numerous packet captures, ap support logs etc. no answers as yet.

Thanks in advance.

2 Messages

 • 

70 Points

3 months ago

yes i am facing same issue with ruckus ZD1200 with AP R720 & T310C setup. tried every setting suggested by ruckus but no luck.

 if any one has solution please update.


Issue: Clients are getting disconnected randomly. 

246 Messages

 • 

4.2K Points

Hi Rahul,

Can you share us more information about the issue?
1. Is it happening for all the clients or with specific models?
2. What is the ZD software version?
3. Did you observed any disconnection reason when the client is disconnected? (like what others has observed in this post).

9 Messages

 • 

174 Points

I am getting disconnection issues with r510 and zd1200 log showing following

2020/09/06 00:04:20 AP Radio On High Radio [5G] of AP[5FL-R-606] is ON Clear
2020/09/06 00:04:20 AP Radio On High Radio [2.4G] of AP[5FL-R-606] is ON Clear
2020/09/06 00:04:18 AP Radio On High Radio [5G] of AP[2FL-R-315U] is ON Clear
2020/09/06 00:04:18 AP Radio On High Radio [2.4G] of AP[2FL-R-315U] is ON Clear
2020/09/06 00:04:17 AP Radio On High Radio [5G] of AP[4FL-R520] is ON Clear
2020/09/06 00:04:17 AP Radio On High Radio [2.4G] of AP[4FL-R520] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [5G] of AP[5FL-R612] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [2.4G] of AP[5FL-R612] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [5G] of AP[7FL-R-801] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [2.4G] of AP[7FL-R-801] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [5G] of AP[3FL-R-416F] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [2.4G] of AP[3FL-R-416F] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [5G] of AP[6FL-R710F] is ON Clear
2020/09/06 00:04:15 AP Radio On High Radio [2.4G] of AP[6FL-R710F] is ON Clear
2020/09/06 00:04:14 AP Radio On High Radio [5G] of AP[7FL-R-806] is ON Clear
2020/09/06 00:04:14 AP Radio On High Radio [2.4G] of AP[7FL-R-806] is ON Clear
2020/09/06 00:04:14 AP Radio On High Radio [5G] of AP[2FL-R-CAG] is ON Clear
2020/09/06 00:04:14 AP Radio On High Radio [2.4G] of AP[2FL-R-CAG] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [5G] of AP[4FL-R-504] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [2.4G] of AP[4FL-R-504] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [5G] of AP[4FL-R-507] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [2.4G] of AP[4FL-R-507] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [5G] of AP[7FL-R-001] is ON Clear
2020/09/06 00:04:13 AP Radio On High Radio [2.4G] of AP[7FL-R-001] is ON Clear
2020/09/06 00:04:13 AP Radio On

AP up time is okay. What could be the reason. Ruckus support asking 700$ for 2 hour support. I don't want to expand that much. Can any one help me with the issues?

I am loosing faith on ruckus

2 Messages

 • 

70 Points

Hi Sanjay, 

This disconnection issue is happening with  devices like desktop which having Tipi link adapter  with ubantu os ,  PDA devices (Honeywell & I-data) , windows laptop. clients those who are associated with T310c having more issue. 

246 Messages

 • 

4.2K Points

3 months ago

Hi Moshiur,

Can you check the AP Support file and find the disconnection event for the client MAC address?
The event should have the disconnection reason.

1 Message

 • 

60 Points

3 months ago

Hi there, I have a similar issue with some of my wireless clients.  Where do I see the disconnection event reason?  I have looked on the console and selected the AP, then I filtered it to just see one particular client's mac address. I can see them leaving and joining the AP but I don't see a disconnection reason .. .am I looking in the wrong place?
Thanks

Employee

 • 

604 Messages

 • 

10K Points

Hi There,

If it is ZD, then you have to change the ZD log settings to "Show all".

Refer the online document from here.

Regards,
Syamantak Omer

Regards,

Syamantak Omer