Skip to main content

4 Messages

 • 

100 Points

Fri, Nov 8, 2019 2:26 PM

Airprint not working on R500 / R510 unleashed

Ever since we switched from rubbish consumer WAPs to Ruckus Unleashed (3x R510, 1x R500), I have never been able to get AirPrint working. It used to work fine with the old WAPs but no matter what I do, it just doesn't work with the Unleashed setup. I have read numerous support threads and tried things like bonjour gateway (which I don't think we would need?), made sure client isolation if off etc but it just does not work.

Can somebody help me please? I've setup numerous Wi-Fi network including Ubiquiti Unifi, Netgear, Ruckus ZoneDirector, Meraki, Cisco but for the life of me, I just can't get unleashed to play nicely.

Help!

Responses

30 Messages

 • 

670 Points

a year ago

Hi Glenn,

I suggest disabling SmartCast.

From the CLI, go into the enable menu, then config, then the WLAN that you're having the issue on. From here, you should enter the command to disable directed multicast.
Here's an example:

enable [ENTER]

config [ENTER]

wlan [ENTER]

no qos directed-multicast [ENTER]

qos directed-threshold 0 [ENTER]


Regards,

Phil.





4 Messages

 • 

100 Points

a year ago

Hi Phil,

Thanks for your help.

I made the changes as you suggested but I am still getting a  'No AirPrint printers found' message on the iPads. Is there anything else I can try please?

Glenn

30 Messages

 • 

670 Points

a year ago

Hi Glenn,

Which version of Unleashed software are you running?
There's further info here:
https://forums.ruckuswireless.com/ruckuswireless/topics/igmp-snooping-and-directed-multicast-on-unle...

Regards,

Phil.

4 Messages

 • 

100 Points

a year ago

We are running 200.7.10.102.64.

I've looked at the article in the link but not really sure what I'm looking at?

366 Messages

 • 

4.7K Points

a year ago

Works for be fine on unleashed 200.6.10.x on a r710.  Only reason I’m not on the newer 200.7.10.x is I find it buggy. I find speed issues on iOS devices on 200.7.10.x ... and I’m not the only one who has this issue on 200.7.10.x. I kept my clients on 200.6.10.x  since they also experienced the same issues on 200.7.10.x.  Ruckus support so far hasn’t acknowledged this issue.

I suggest that you run a speed test on your r510 aps using ruckus SpeedFlex and see what speeds you are getting and see if you are getting extreme slow downloads.

if you are.I suggest rolling back to 200.6.10.x and see if that helps your AirPrint issue too. I just find too many issues with 200.7.10.x since they changed WiFi drivers from what I can tell.

4 Messages

 • 

100 Points

a year ago

I have now had a chance to try rolling back to previous firmwares - 200.6.10.1.310 and 200.5.10.0.235 - as suggested here and in another thread and it has made absolutely no difference. I still can't find the printer on my network. Bonjour and Airprint are active on the printer and I Can browse to the printers web interface from the iPad so I know that there is connectivity. AirPrint is just refusing to work.

I'm just about ready to give up this. I'll never buy Ruckus again. I've installed a couple of Unifi networks since and never had any issues like this.


366 Messages

 • 

4.7K Points

Anyway, sorry you are frustrated, but yeah. Unifi has it's own issues too. Of all the years I have ruckus .....never had airport issues  besides a really bad printer MFP from Samsung which kept crashing.

366 Messages

 • 

4.7K Points

a year ago

Glenn, by any chance did you test the wifi speed? at this point I don't think your AIrprint issue is a firmware issue.  What printer do you have? how is it connected Wifi or ethernet?  What router are you using?

Airprint works fine for me then again I have a HP 426dw

366 Messages

 • 

4.7K Points

a year ago

Also my clients are unleashed 200.6.10.x and don't have issues with airport... varies different printers Canon MF Color Lasers, HPs, Brother printers..  Just wondering what else is on your network? router, switches etc...

366 Messages

 • 

4.7K Points

a year ago

Might be a rare bug.......
as seen in another thread, but printers do you have?.....you might consider taking the other APs offline for now...if you want to do some troubleshooting....just use the r510 and did a hard reset ...stick with firmware 200.6.10.X....
 https://forums.ruckuswireless.com/ruckuswireless/topics/airpint-not-working-on-200-6-10-1-310