Skip to main content

9 Messages

 • 

242 Points

Thu, Apr 25, 2019 9:39 AM

multiple vlan with different DHCP pool

Hi Guys, 

I need some help, i am using an 7450-24p with an router image running on version 08.0.80e.

i enable dhcp server on the switch. i am trying to have 2 vlans with different ip subnet. 

below is my config, did i miss or do anything wrong over here? as i am not able to get any ip from it.

show run

Current configuration:
!
ver 08.0.80eT213
!
stack unit 1
  module 1 icx7450-24p-poe-port-management-module
  module 2 icx7400-xgf-4port-40g-module
  module 3 icx7400-qsfp-1port-40g-module
  module 4 icx7400-qsfp-1port-40g-module
!
global-stp
!
vlan 1 name DEFAULT-VLAN by port
 spanning-tree
!
vlan 10 name IP-subnet_192.168.1.0/24 by port
 untagged ethe 1/1/1 to 1/1/12 
 router-interface ve 10
 spanning-tree 
!
vlan 20 name IP-subnet_192.168.2.0/24 by port
 untagged ethe 1/1/13 to 1/1/24 
 router-interface ve 20
 spanning-tree
!
ip dhcp-server pool wifi
 excluded-address 192.168.1.1 192.168.1.10
 lease 1 0 0
 network 192.168.1.0 255.255.255.0
 option  3 ip 192.168.1.1  
 option  6 ip 8.8.8.8 
deploy
!
ip dhcp-server pool smart
 excluded-address 192.168.2.1 192.168.2.10
 lease 1 0 0
 network 192.168.2.0 255.255.255.0
 option  3 ip 192.168.2.1  
 option  6 ip 8.8.8.8  
 deploy
!
interface ve 10
 port-name wifi
 ip address 192.168.1.1 255.255.255.0
!
interface ve 20
 ip address 192.168.2.1 255.255.255.0

Responses

Employee

 • 

129 Messages

 • 

46 Points

2 years ago

Hey Dan, 

Do you have "ip dhcp-server enable" in your configuration? It is a global command. 

Support - 1-855-782-5871
https://support.ruckuswireless.com/contact-us

9 Messages

 • 

242 Points

Hi Ben, Yes dhcp-server is enable.

Employee

 • 

129 Messages

 • 

46 Points

Interesting. I don't see anything wrong in your configuration although it is just a snippet. Are you learning mac-addresses probably on the ports? "show ip dhcp-server summary" and "show ip dhcp-server binding" should give you a clue about whether the switch is trying to serve addresses. 

Support - 1-855-782-5871
https://support.ruckuswireless.com/contact-us

9 Messages

 • 

242 Points

yea i dont get it why is not working... i will get "show ip dhcp-server summary" and "show ip dhcp-server binding" to show you when i am back to office.. anything else i should check? 

Employee

 • 

129 Messages

 • 

46 Points

Hard to say off just that configuration. I see you are on old spanning tree (802.1d). You may want to move to 802.1w for faster convergence as 802.1d is pretty slow.The command is "span 8" at the vlan level. "show log" should also give you some clues as to if the switch is trying to give out addresses. If we can't get a clue out of these outputs, it may just be easier to open a case and have an engineer look at it with you. 

Support - 1-855-782-5871
https://support.ruckuswireless.com/contact-us

9 Messages

 • 

242 Points

got it working thanks to Abilash... i turn on dhcp-client instead of server hahah... thanks ben! 

3 Messages

 • 

132 Points

2 years ago

Maybe you could try adding an "ip helper-address" to the ve interface.
That's what I use, but my dhcp server is external.

Employee

 • 

129 Messages

 • 

46 Points

He shouldn't need that here since he is serving directly attached vlans. If the server was on an external network like you mentioned, then we would use a helper. 

Support - 1-855-782-5871
https://support.ruckuswireless.com/contact-us

232 Messages

 • 

4K Points

2 years ago

If you plug a TAP (Wireshark or your preferred sniffer) into a untagged  Vlan 10, or vlan 20 port, are you seeing your target device's DHCP Requests? This is where I'd go now. try and see if DHCP is responding with a NAC, or if your Target device is being outright ignored, or isn't seen. Can you produce a scenario where DHCP works on this switch at all?

126 Messages

 • 

2.7K Points

2 years ago

Hi Dan,

Upon checking the configuration which is given above it looks like you have not enabled DHCP globally that is the reason why its not working.

If globally if it is enabled, we should see that in the configuration as below.

aaa authentication web-server default local
aaa authentication login default local
enable telnet authentication
enable aaa console
hostname MDF-CORE
ip dhcp-server enable
!
ip dhcp-server pool 1
 dhcp-default-router 192.168.8.100
 dns-server 8.8.8.8 8.8.4.4
 excluded-address 192.168.8.99 192.168.8.140
 lease 0 4 0
 network 192.168.8.0 255.255.252.0
 deploy
!
!
ip dhcp-server pool 206
 dhcp-default-router 10.206.0.1
 dns-server 8.8.8.8 8.8.4.4
 excluded-address 10.206.0.1
 excluded-address 10.206.0.25
 lease 0 0 5
 network 10.206.0.0 255.255.224.0
 deploy
!
!
ip dhcp-server pool 207
 dhcp-default-router 10.207.0.1
 dns-server 8.8.8.8 8.8.4.4
 excluded-address 10.207.0.1
 lease 0 0 10
 network 10.207.0.0 255.255.224.0
 deploy

Regards,
Abilash PR.

9 Messages

 • 

242 Points

omg thanks Abilash! stupid me i turn on dhcp-client instead of server hahaha it works now thanks!!