Skip to main content

Wed, Dec 19, 2018 11:48 AM


ICX7150 no output show inline power

Hi All

We have an ICX7150-24P-4X1G POE 24-port, with  10 R510 AP's.

All the AP's are down but switch is up leading to me a POE issue. 

Switch has been rebooted with no change, However there is no output to the sh power inline command. 

would the POE module failing cause there to be no output?




20 Messages


646 Points

2 years ago

Hello Imran,
First you can try to have help from support by opening a case on the site.
Your analysis should be good.  This could be a PoE module fail or PoE Firmware issue.
You can have a deeper look at this with the following command: show poe detail and looking for the Firmware version. If this indicates 0.0.0 version you can try to reload the PoE file to the switch.

36 Messages


810 Points

2 years ago

The correct command to show power is show inline power.  Depending on your ICX version you may need to enable power on each port.  In earlier versions the power was default off unless you enabled it on the port.  

try this to enable poe on all ports of your 24 port switch

config t
int e 1/1/1 to 1/1/24
inline power

9 Messages


346 Points

2 years ago

Hello Imran

In order to find what is the cause of this issue, we need to analyze the following:

Was the switch providing POE correctly before or is this new implementation?

Is the output "show inline power" the one not showing anything?

Have you tried the command "show inline power detail" , what do you see in it?  (POE firmware version has like different numbers or build 0, or see anything like Hardware version UNKNOWN) ?

What Software image version is the switch running?

Have you tried to disable and re enable power in the interfaces?

If you see those errors and if upgrade to the latest version for example 8070c, does not fix the problem please open a new ticket.


2 Messages


82 Points

2 years ago

Hi All, 

Thank you for your responses, I forgot to add, site was live with all AP's working before today. 
I have pasted the output of POE detail below - curiously empty...

poe inline is enabled on all ports 

sh poe detail

Power Supply Data On unit 1:

Power Supply Data:

POE Details Info. On Unit 1 :

General PoE Data:


Cumulative Port State Data:

#Ports    #Ports     #Ports   #Ports    #Ports       #Ports     #Ports
Admin-On  Admin-Off  Oper-On  Oper-Off  Off-Denied   Off-No-PD  Off-Fault

Cumulative Port Power Data:

#Ports  #Ports  #Ports        Power       Power
Pri: 1  Pri: 2  Pri: 3  Consumption  Allocation



100 Messages


2.1K Points

2 years ago

As Vincent suggested try reloading the PoE firmware. I would suggest upgrading to 8.0.70d and the PoE upgrade will be done automatically. 

If that does not help you should open a TAC case as the switch will probably need to be RMA'd.