Skip to main content
B

Thu, Mar 11, 2021 2:00 PM

Power Failure Causes Switch to reboot into Router Mode

I have a ICX 7150 C12 Ruckus Switch provided to me by my home builder Lennar with two R510 APs. We had a power outage in my area and it caused the switch to boot into router mode when it should be in switch mode. This is causing my system to do some weird things and we didn't have this problem before the outage.

How do I go about fixing this? The home builder Lennar initially set everything up for us so I am unfamiliar with the majority of the setup process. I will need a step by step instruction as I understand the basics but I am also very new to this. It was asking me for a password in the Unleashed app but I don't have one for the switch only the router, will I need to factory reset the system? If so how will I go about factory reseting?

I will then need help figuring out how to connect to the switch so I can make the changes needed. Is it as simple as typing in the address on the switch into the browser URL like I would a router? Or do I need to manually plug into the switch via ethernet or some other way? After I figure that out I will need to know how I go about changing it. Is there a command prompt and if so what commands do I type to get it to boot into the proper mode? Also, is there a way to keep it from booting to router mode every time there is a power outage?

Responses

Official Rep

 • 

885 Messages

 • 

13K Points

1 m ago

Hi Brock,

All you need to do is access the CLI of ICX switch and change the boot image from router to switch.

Below are the useful commands

- show flash or show version. || To check what image is in use currently.
- Boot system flash <primary or secondary || This on privilege mode will make switch to reboot and run the flash (primary or secondary)
- Boot system flash <primary or secondary || On configure terminal will configure the switch to boot after any reload with the flash you select. by default should boot with primary
For more info, refer below link.

Regards,

Syamantak Omer

5 Messages

 • 

110 Points

1 m ago

Brock,

Have you been able to resolve the problem, did rebooting using primary (switch) flash help? I have a very similar one, but in my case the switch can't boot using primary flash for some reason, so I still have router flash...

Official Rep

 • 

190 Messages

 • 

2.8K Points

1 m ago

Hi Brock,

Hope you were able to boot with the switching image, You can also open a support case to walk you thru the cli and explain the boot system options if not clear.

Thanks

Jijo 

2 Messages

 • 

80 Points

Hello Jijo,

I attempted to connect a usb-c to usb-a cable to my computer and access the cli but I did not get any success. I decided to follow your advice and I put in a support ticket for this issue as I am in a little over my head on this.

Thanks for the advice.

5 Messages

 • 

100 Points

4 d ago

Hey Brock, I encounter this issue quite often. I did a write up 4 months ago that may help if you are comfortable with CLI: https://forums.ruckuswireless.com/conversations/ruckus-at-home/ruckus-icx7150c12-switch-is-frequently-dropping-internet-connection/5fd188a05fcf364c35d03a79?commentId=5fd45ccc4d73274b86d66940

My problem is I've seen some other posts mention they can flash the switch image to both partitions, but I haven't succesfully done this yet. This causes a mountain of headaches whenever something networking pops up I have to check if the switch rebooted.