B

4 Messages

 • 

152 Points

Fri, Jan 14, 2022 12:13 AM

Firmware upgrade

I have tried twice to upgrade the firmware on my R510.

It is currently running 200.10.10.5.253 and I want to upgrade to 200.11.10.5.195.  I am performing an online upgrade.

It appears to flash properly but once the AP is rebooted it tells me to downgrade to 200.10.10.5.253 which I am able to do.  It appears this is a known problem as I have found several mentions of it on various Google searches.  Unfortunately there is not a known resolution I have found.

Any assistance would be most appreciated.  Thank you.

Accepted Solution

20 Messages

 • 

252 Points

10 d ago

Hi Brain,


It does not look like any issue with the firmware upgrade, as on the top it is showing that the AP has the latest firmware 200.11.10.5.195.

The downgrade button is visible now because you are on the highest available firmware available for Unleashed product.
Its just an information on the page which tells you the written part in red if you hit downgrade the firmware, if not you will stay on the updated firmware.


"The system will be downgraded to the specified version of 200.10.10.5.246, and restored configuration to 200.10.10.5.246 ."


Hope this answers your question.

4 Messages

 • 

152 Points

Vijay,

Thank you for replying.  I've been looking forward to your answer.

In the past when I have upgraded the firmware there was no indication for a downgrade to the previous version which is why I was concerned when I saw this, especially given that it's in red!

I have to admit, it does appear to be working fine though!

It would be helpful if something like the following was inserted into the release notes:  "The message 'The system will be downgraded to the specified version of 200.10.10.5.253, and restored configuration to 200.10.10.5.253' can safely be ignored as it's only for informational purposes and the firmware upgrade was successful."

Thank you once again for your assistance.  Much appreciated.

20 Messages

 • 

252 Points

Hi @brian_elkins ,

Thanks for the update and choosing Ruckus.

Vijay Kuniyal

Staff Technical Support Engineer

CCNA RnS | CCNA Wireless | RASZA | Meraki CMNO

20 Messages

 • 

252 Points

13 d ago

Hi @brian_elkins ,

Did you try performing the upgrade manually/offline by downloading the firmware.

https://support.ruckuswireless.com/software/3176-ruckus-unleashed-ap-200-11-10-5-195-ga-software-for-r510

Vijay Kuniyal

4 Messages

 • 

152 Points

12 d ago

Vijay_Kuniyal,

Thank you for taking the time to reply.  Yes, I have tried a local upgrade and that fails as well unfortunately.

One thing I noticed in the release notes is the highest version listed for online upgrading or local upgrading is 200.10.10.5.246 (page 7 on the below link) and I am running 200.10.10.5.253.  I don't know if this is an oversight in the release notes or perhaps I have to downgrade to 200.10.10.5.246 before upgrading to 200.11.10.5.195.  It seems odd that one would have to do that though.

https://support.ruckuswireless.com/documents/3944-ruckus-unleashed-200-11-ga-release-notes/download

Here is what I have discovered at this point:

Prior to performing an online or local upgrade I start with the following:

After having performed the online or local upgrade I receive the following and I downgrade as instructed:

At this point I remain with 200.10.10.5.253 on my R510s.

I noticed in browsing the forums there were suggestions to try different browsers.  I tried Chrome and Edge with identical results.

(edited)

Official Rep

 • 

1.4K Messages

 • 

18.6K Points

8 d ago

Hi Brian,

If you are on 200.7 or above, you can directly upgrade to any higher version, as following upgrade path is not required.

Now coming to your issue, upgrading Unleashed from online server give you two options.

1. Upgrade to latest available version.

2. Downgrade to last version (if your Unleashed was upgraded from a past version which is still available on online upgrade server).

As per the 2nd screenshot in your last comment, it clearly says your controller is running on 200.11 (current version) and if you want, you can downgrade to older version (the one listed in dropdown menu).

This is expected.

May I know what issue you are facing now?

Important Announcement