Skip to main content

2 Messages

 • 

80 Points

Fri, Oct 9, 2020 1:31 PM

I have a ICX 7150 that is considered a "brick". I can not get the TFTP or ping to work

I have a ICX 7150 that is considered a "brick". I can not get the TFTP to work...Can not even get the ping command to work.  Does anyone know of any command that will bring the basic network function back in order to TFTP?

ICX7150-Boot>printenv
baudrate=9600
ipaddr=192.168.1.30
serverip=192.168.1.41
 netmask=255.255.255.0
gatewayip=192.168.1.1
uboot=mnz10115.bin
ver=10.1.15T225 (Jan 30 2019 - 23:08:47 -0800)
 Environment size: 166/16379 bytes

ICX7150-Boot>ping 192.168.1.30
ERROR: gmac_set_speed: Invalid GMAC speed(0
)! at ../drivers/net/bcm-xgs-eth-gmac.c:757/gmac_set_speed()
Using bcm_xgs_gmac-0 device

 ARP Retry count exceeded; starting again ping failed; host 192.168.1.30 is not alive

ICX7150-Boot>

Responses

Employee

 • 

100 Messages

 • 

2.1K Points

a month ago

Hi Keith

You switch does not have it's operating system so is stuck at the boot level, instructions on how to recover a switch in this condition are here https://docs.commscope.com/bundle/fastiron-08095-upgradeguide/page/GUID-9B5D5A56-039D-44FB-8FD2-B9B5...

Alternatively you can open a support case and have the switch replaced under it's lifetime warranty https://support.ruckuswireless.com 

2 Messages

 • 

80 Points

a month ago

Thanks Simon, The recover instructions do not work since the switch can not perform basic network functions.  It can not even ping itself and there is no link on any of the ports.  BTW, i am an employee as well.  I did speak with support and they did suggest to get a new switch.  I am hoping that I can save this one -- I now consider this a challenge:).  If I was able to get the TFTP working, then it would be easy to bring it back, but as of right now it is not working.

Official Rep

 • 

83 Messages

 • 

1.5K Points

a month ago

It happened to me today as well.  I am trying to stack two 7150 and hoping factory resetting the second 7150 would just automatically join the slack but found it is running mismatch firmware.  So I factory reset it again and hoping it would just get an IP address for management, and I can use Unleashed to upgrade the firmware to match the first 7150.  But after second factory reset, it does get an IP address but not responding to ping, or very occasionally a few successful ping packets but definitely unable to ssh to it. 

Long story short, I simply load the matching image using USB drive, problem solved, as long as you are not running the FIPS version of ICX.

Good luck.

https://docs.commscope.com/bundle/fastiron-08095-upgradeguide/page/GUID-A66595C5-FDA6-4053-AC95-A122...  

Employee

 • 

81 Messages

 • 

1.9K Points

a month ago

Hi,
You are not pointing to the image file also you need to have tftp  server ip and gateway the same.  Make sure it is connecting on the management ethernet connection to your tftp server.

If you look at your environment we see:
ICX7150-Boot>printenv
baudrate=9600
ipaddr=192.168.1.30
serverip=192.168.1.41
 netmask=255.255.255.0
gatewayip=192.168.1.1
uboot=mnz10115.bin
ver=10.1.15T225 (Jan 30 2019 - 23:08:47 -0800)
 Environment size: 166/16379 bytes

Can you keep your gateway and serverip the same and run commands:
 setenv gatewayip=192.168.1.41
 saveenv

After that you do the following:
ping the tftp server, if it works then make sure the image is on the root of tftp server the n do following based on the image you have:
 setenv image_name SPR08090g.bin (what ever image name you chsooe for the right type of ICX model)
 saveenv
 update_primary
 update_secondary
 update_uboot
 reset

Also if you are going from any 8080 or below code please first upgrade to 8080f non UFI reload then  then go to 809x UFI image
Hope this helps.

Thanks
Hashim