Skip to main content

7 Messages

 • 

162 Points

Wed, Sep 4, 2013 7:06 PM

Motorola MC9090 handhelds and 7363 Access Points with Zone Director

I have 4 motorola handheld guns roaming between 6 overlapping 7363 access points with Zone Director 1100. The guns are running a simple wavelink telnet application. They are sitting on a separate open WLAN with no authenticaion but with an MAC ACL. Intermittently, the guns are having problems re-establishing a link to the access point(bars that indicate signal strength go from full to none, and the handheld indicates that it lost connection with the server), even though they are within the range of them. It doesn't happen often but its annoying enough. It usually takes 10 - 20 seconds to re establish a link. What settings should I check? Thank you!

I

Responses

368 Messages

 • 

5.6K Points

7 years ago

I would save a debug log, and AP logs and open a case at ruckus, but I'd also turn on a packet capture and try and analyze some packets.

I'd say it's a Motorola problem. It usually is.

8 Messages

 • 

112 Points

7 years ago

I am have the same thing going on with the Motorola MC9090 handhelds and have not found a way to get it working. Any help would be nice.

9 Messages

 • 

160 Points

7 years ago

Do you have ChannelFly enabled? If so the Moto devices don't support the 802.11h pre-emptive channel change notification and so when the AP changes channel the symptoms are that the device will lose wireless connectivity for 20-30 seconds. If this is the cause then either just use background scanning for channel change of static channel plan (of course you should know your RF environment to do this so that you are not placing APs on channels where there is interference!).

Devices like iOS and Android do support .11h and seamlessly follow channel changes when ChannelFly is enabled.
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

7 years ago

If the scanners only support channels 1/6/11, only use Background Scanning.
For intermittent packet drops, try 9.5.3.0.44 available now under Downloads.

99 Messages

 • 

2K Points

7 years ago

@Michael Daracz

Hi Michael, from your description it seems like the client is not roaming as quickly as it should. Some assumptions:
1. The scanner are set to operate on one band only, 2.4 or 5 GHz not auto
2. If using 2.4 the scanners are NOT 802.11b only
3. Your deployment has a good overlap (so an signal of no less than -65 dBm everywhere)

Base on those assumption and what you have indicated try the following:
1. Set the wlan to tunnel mode (this is recommended for handheld and phone)
2. Set the BSS min rate to something higher than the default so the scanner will get "out of range" while still able to communicate quite well and when looking for a new AP it should still get a good enough signal on the new AP and connect right away.

With a -65 dBm coverage it's safe to start with a BSS min rate of 12 Mbps. This wil make the AP send out management frames, such as beacon and probe response be sent out at 12 Mbps so the client can not get too far before it get out of range of a 12 Mbps radius of the current AP. Here are the command to set the BSS min rate for the wlan:
ruckus> enable
ruckus# config
ruckus(config)# wlan motoscanner
The WLAN service 'motoscanner' has been created. To save the WLAN service, type 'end' or 'exit'.
ruckus(config-wlan)# bss-minrate 12
The mgmt-tx-rate will be set to the same value as bss-minrate.
The command was executed successfully. To save the changes, type 'end' or 'exit'.
ruckus(config-wlan)# end
The WLAN service 'motoscanner' has been updated and saved.
Your changes have been saved.
ruckus(config)# end
Your changes have been saved.
ruckus#

5 Messages

 • 

140 Points

7 years ago

jumping into the thread.... :)

I have exactly the same issue (and the very same application is being used here also) [Michael.. could you confirm your encryption settings that you are using.. i.e. WPA or WPA2 for example?]

Currently tunnelled wlan with wpa/tkip is failing at one of our sites (the other site is setup identically without the random drop outs.
It appears that some of the devices will work fine when being used but when idle for x amount of time (CAM mode on and CPU performance activated) the devices stop passing IP traffic but both the unit and the zone director say they are connected with an IP address still visible but with failed pings. if you deleted the device from the monitor - currently active clients page the device reconnects instantly and allows in this case the telnet session to work (and pings!)

I will try and update the wlan profile to match the above post and report my findings tomorrow....

9 Messages

 • 

160 Points

7 years ago

I have another customer reporting similar issue with Windows CE Mobile 6.5 / Motorola MC9190. It seems when roaming between AP’s as they frequently do it upsets a Telnet connection to a server located externally through the internet. I have to renew their IP to get them communicating again although the ZD thinks they are still connected with excellent signal strength.

They are running latest 9.7 LCS and were already tunnelling with ofdm-only enabled. I have asked them to set bss-min rate to 12 to see if that helps and they were also going to test smart roam.

1 Message

 • 

60 Points

Eddie,
What was your resolution to this issue? I am currently experiencing the same.

I have another customer reporting similar issue with Windows CE Mobile 6.5 / Motorola MC9190. It seems when roaming between AP’s as they frequently do it upsets a Telnet connection to a server located externally through the internet. I have to renew their IP to get them communicating again although the ZD thinks they are still connected with excellent signal strength.

They are running latest 9.7 LCS and were already tunnelling with ofdm-only enabled. I have asked them to set bss-min rate to 12 to see if that helps and they were also going to test smart roam.

7 Messages

 • 

162 Points

7 years ago

@Sid Sok

First two assumptions are correct

I have updated the BSS and I will get back in 2 days.

8 Messages

 • 

112 Points

Did you end up getting it working with the BSS update?:

8 Messages

 • 

112 Points

7 years ago

@Michael Daracz

Did you end up getting it working with the BSS update?:

2 Messages

 • 

70 Points

7 years ago

BSS Update wiil help in this case the biggest issue is the DTIM period you need to set the DTIM period to at least 5 on the WLAN the Motorola is associating to Moto recommend 10 also the short preamble could also cause issues
Brand User

Former Employee

 • 

2.6K Messages

 • 

44.8K Points

7 years ago

Both official ZD releases 9.6.2.0.13 (MR2) and 9.7.0.0.220 (GA) are now available
if you were on a patch or LCS build. Frequent roaming and a hostonly, loopback
detected state could result in 10s silent periods or one-way audio for VoIP devices,
certain to also break any Telnet-based applications like Citrix, or RDP. That bug fix
is in both official releases.

And maybe for a Moto only environment, but I can't advise increasing DTIM past 5.

30 Messages

 • 

402 Points

7 years ago

Hi,

We have something very simillar, we run 65 handhelds across 11 AP and a zonedrirector (9.6.1.0 build 15). The handhelds are Win CE5.0, the network cards in them are BG. We run a web-based application through the built in Internet Explorer browser and we get a lot of "web page not found", the server sit's in the warehouse for this application.

We are planning an upgrade to 9.6.2.0.13 in the next few weeks hoping this will resolve our issues.

Julius

9 Messages

 • 

160 Points

7 years ago

The things to try are:
- Enable OFDM only and set BSS Min Rate = 12 on the device WLAN
- Upgrade to one of the version Michael mentions with some loop fixes
- Try setting a higher DTIM value on the APs for the device WLAN (seems 5 is recommended for Moto devices). This is currently a bit painful as you can't do it via the ZD WebUI so have to CLI to every AP and check you are applying it to the correct WLAN (if you only have 1 WLAN then its designator will be the same on every AP so you could do it with the ZD CLI remote_ap_cli command)
- Enable RTS-CTS protection on the WLAN

11 Messages

 • 

192 Points

Thanks Eddie, I will give this ago. I just need some info how to setup the following:

-Enable ODFM
-Enable RTS-CTS

I'm assuming that I would be able to use the following command to set the DTIM on the ZD CLI: remote_ap_cli –A “set dtim-period wlan2 1”

Where wlan2 is my wlan that all handhelds are connect on and the number 1 represents the DTIM setting I want which in my case would be 5?

Thanks,
Julius

30 Messages

 • 

402 Points

Thanks Eddie, I will give this ago. I just need some info how to setup the following:

-Enable ODFM
-Enable RTS-CTS

I'm assuming that I would be able to use the following command to set the DTIM on the ZD CLI: remote_ap_cli –A “set dtim-period wlan2 1”

Where wlan2 is my wlan that all handhelds are connect on and the number 1 represents the DTIM setting I want which in my case would be 5?

Thanks,
Julius

368 Messages

 • 

5.6K Points

Enable OFDM-only (per WLAN)

set ofdm-only : set ofdm-only {enable|disable}
-- Enable/Disable OFDM-only mode (exclude 11b CCK rates)

Sure hope RW will make it a global feature, not just per WLAN

About enabling RTS-CTS, I'm not too shure, but I think it's this

set rts-thr : set rts-thr {disable|}
-- Modify Request to Send threshold

You need to set a threshold. I would set it at size just below what your handhelds are sending data at so it will kick in.

9 Messages

 • 

160 Points

You can enable OFDM only and configure the bss min rate in the ZD CLI per WLAN, rather than having to do it on the AP using set commands:
Login to ZD CLI - "en"able mode - "config" mode - "wlan xxx" (wlan name is case sensitive)
"ofdm-only"
"bss-minrate 12"
"end"
"show wlan" to show the configuration is set.

In relation to remote_ap_cli –A “set dtim-period wlan2 1” that looks correct (with a 5 in your case). The only issue is that depending on how the APs are provisioned with WLANs (maybe different WLAN on different AP, provisioning order) they won't all necessarily be called wlan2. Note this is not the wlan name you give the wlan, but an internal wlan identifier - 2.4Ghz start at wlan0 and 5Ghz start at wlan32 (on later code releases). You can get get the wlan name-SSID mapping using "get ssid wlanx" i.e.
rkscli: get ssid wlan0
wlan0 SSID: Test
This way you will find what wlan name to use for each AP (if you are lucky it might be the same for all APs!).

In relation to RTS-CTS as Primož says its "set rts-thr {disable|}". Again you will need to know the correct wlan identifier. Generally the advice is to set the threshold to a size larger than max single frame size as you probably don't want RTS-CTS for all packets, just the larger ones that will use more airtime. In 11g the recommendation was 2346, but since 11n aggregation it supports up to 65535. I would change the other settings first, monitor and if still having issues then try RTS-CTS at 2340.

30 Messages

 • 

402 Points

Thanks very much Eddie and Primoz, will try these setting in the next few days, hopefully even over the weekend.

368 Messages

 • 

5.6K Points

7 years ago

For excecuting commands on APs via ZD read this KB article

https://support.ruckuswireless.com/an...

8 Messages

 • 

112 Points

7 years ago

Is there and documentation in how to set the DTIM value in the ZoneDirector?