mrmadgig's profile

9 Messages

 • 

150 Points

Mon, Mar 22, 2021 7:29 PM

NIC Ports on the AP's

Hello

Looking to see if anyone has the answer to this? I have a R710 connected to a ZD1200 and I want to change the network ports on the AP one as trunk (which it is be default) and the other one an to an access port to set a native VLAN on the second for a camera. Doesn't seem to respond that way. Can't find any docs on this. Do the ports actually work in this manner? If it is configurable this should be no problem.

Brand User

Official Rep

 • 

65 Messages

 • 

816 Points

7 m ago

Hi there - I don't have a link to a document that says no. However, I asked the same question internally and was told no, it does not function that way.

9 Messages

 • 

150 Points

Thank you I though I heard that also once before. 

Official Rep

 • 

1.2K Messages

 • 

17K Points

7 m ago

Hi,

So you want AP uplink (connected to SW) as trunk and other port access with some VLAN, right?

This is possible!

By default, AP's trunk port has VLAN 1 as untagged and rest everything is tagged. All you need to do, configure the 2nd port as access port with desired VLAN.

If SW port has trunk configured with correct VLANs, your camera should get an IP.

Here is the online doc page explaining how to change AP eth port settings and VLAN setting.

https://docs.commscope.com/bundle/zd-10.4.1-userguide/page/GUID-4C5B4CF4-FF7F-4F53-9E5C-359769D316B7.html

9 Messages

 • 

150 Points

Thanks but I tried this way before posting and it does not work. 

Official Rep

 • 

1.2K Messages

 • 

17K Points

I don't have physical access to any AP, let me check once and get back to you.

Regards,

Syamantak Omer

Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Follow me on Linkedin

445 Messages

 • 

5.5K Points

7 m ago

This definitely should work. Just check, if you are configuring correct port (numbering is not that obvious, check  pictures in ZD interface). For this to work, port on switch must be  trunk with proper tagged and untagged VLANs configured, and secondary port must be enabled.  This is a picture from actually working AP with 2 VLANs (old ZD1100 with ZF7352):

As you can see there, PoE port connected to switch is LAN2, but secondary port is actually LAN1 !

In newer versions there are additional settings as WAN trunk and LAN trunk, and to have successful communication with network for second port uplink port must be LAN trunk, not WAN (otherwise no DHCP address will be received, etc.):

Most probably you have uplink port configured as WAN trunk, change it and it should work.

If you don't have physical access to AP, be very careful configuring uplink port,as if you make a mistake, you may end up resetting AP to factory setting, which will require physical access.

Hope it helps.

(edited)

9 Messages

 • 

150 Points

Thank you. I do believe I did this and it doesn’t work. However I will try it again. 

so to be clear. Port connected to switch will be LAN TRUNK ON AP. and of course switch will be a trunk port. 

Port not connected to switch will be set as  ACCESS PORT AND UNTAGGED 7. 

thanks 

Official Rep

 • 

1.2K Messages

 • 

17K Points

Port connected to switch will be LAN TRUNK ON AP. and of course switch will be a trunk port. 

Port not connected to switch will be set as  ACCESS PORT AND UNTAGGED 7. 

Yes, refer below assuming VLAN 1 is native VLAN and also used for unleashed AP management and VLAN 20 for the 2nd port of AP where you are connecting UE directly.

Config as per above use case:

Switch port type Trunk

VLAN 1 or any desired VLAN as Untagged/native VLAN

VLAN 20 Tagged

AP uplink port (The one connected to the switch directly):

Trunk (No need to tag VLANs as VLAN 1 is un-tagged and rest all VLANs are tagged by default)

AP's 2nd port (here you will connect your laptop or any other UE directly)

Access port with VLAN 20

Regards,

Syamantak Omer

Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Follow me on Linkedin

9 Messages

 • 

150 Points

Hi Thanks but it does not work. This is my actual config.

LAN two is on VLAN 2 which is 172.16.100.0/24  

I still get 10.10.111.0/24  with PC connected.


interface GigabitEthernet1/0/1
 switchport mode trunk
 spanning-tree portfast edge
 spanning-tree bpduguard enable
end

3560-CX#

Official Rep

 • 

1.2K Messages

 • 

17K Points

As per the switch port config, I feel VLAN 2 is missing on the trunk port.

Please add VLAN 2 as tagged VLAN to this trunk and test again.

Regards,

Syamantak Omer

Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Follow me on Linkedin

9 Messages

 • 

150 Points

It cannot be missing on a Cisco Switch

If the port is a trunk and the VLAN is configured on the switch

I allowed ALL VLAN on the trunk All VLANS are tagged. This is how Cisco switch works.

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/1     on               802.1q         trunking      1
Te1/0/2     on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/1     1-4094
Te1/0/2     1-4094

Port        Vlans allowed and active in management domain
Gi1/0/1     1-2,25
Te1/0/2     1-2,25

I know that the switchport is correct because I plugged a tagged device into it simulating an Access port doing the same and it gets the correct VLAN and subnet. So if I am correct this model does not work. 

Important Announcement