nadir_shah's profile

9 Messages

 • 

160 Points

Tue, Oct 29, 2019 6:16 AM

can not connect ICX 7250-24 with Opendaylight oxygen controller

Hello Everyone,
I have ICX 7250-24 switch and ODL oxygen version. I have connected the ethernet interface 1/1/1 to the  ODL controller. the controlling is running on ip address 192.168.2.25 port 8181. I have enabled the openflow ofv130 and have connected with controller using no ssl in Config mod. Then I enabled openflow layer23 on ethernet interface 1/1/1 with VLAN1  However, the switch is not getting connected with the controller. When I disabled openflow and assigned ip address to 1/1/1 ethernet interface, then the controller is pinged. However, it is necessary that the ip address should not be assigned to ethernet interface 1/1/1 if we want to enable the openflow. When the ip address is not assigned to the ethernet interface 1/1/1, then the switch cannot ping the controller. Can you help me in this regard?
thanks!
Nadir


Responses

Official Rep

 • 

207 Messages

 • 

3K Points

2 y ago

Hi Nadir,

Make sure your Management interface is up and hope ICX and controller are on same subnet , if that is not the case route it thr default gateway with necessary routes added.


Thanks

Employee

 • 

22 Messages

 • 

538 Points

2 y ago

Hi Nadir - Like Jijo said, please double check IP configuration on the ICX and the controller. If they're directly connected, make sure they're on the same vlan/subnet.  It would help you could 'cut and paste' the 'show run' and 'show openflow' outputs here.

Thanks,

Vu

9 Messages

 • 

160 Points

2 y ago

Hello Vu,
thanks for your comment. Actually the problem is that the IP address cannot be configured on the interface that has openflow enabled on. Without configuring IP address on the interface, the router cannot be connected to  ODL
Thanks!
Nadir

Employee

 • 

22 Messages

 • 

538 Points

2 y ago


Hi Nadir - I believe we need a dedicated 'Ethernet' port for ip management. In other words, port with openflow enable will not able to configured with an ip address to carry switch's management traffic. Below is a couple examples/scenarios how to set this up. If you still run into issues or have more questions, please open a support-case so one of us can help.  Thanks. Vu

******
******
Example 1:
ICX running Layer2 (switching code):
ODL server: 192.168.2.25/24
ODL server directly connected to ICX port 1/1/1

On ICX:
config t
int e 1/1/1
no openflow enable
exit
ip address 192.168.2.26/24
ip default-gateway 192.168.1.1 (optional if need to route management traffic elsewhere. ICX would need a router 192.168.1.1)
exit

write mem

//you should be able to ping ODL now!


******
******
Example 2: ICX running Layer3 (routing code):
ODL server: 192.168.2.25/24
ODL server directly connected to ICX port 1/1/1

On ICX:

config t
int e 1/1/1
no openflow enable
exit

vlan 10
untag e 1/1/1
router-interface ve 10
exit

interface ve 10
ip address 192.168.2.26/4
exit
write mem

//you should be able to ping ODL now!
******


9 Messages

 • 

160 Points

2 y ago

Hello Vu,
thanks for the reply, the pinging is done following the layer3 commands. However, when I connect to ODL controller using "openflow controller ip-address 192.168.2.25 no-ssl port 8181" it gives me error like "ERROR: Ctrl-1 in ver 1 sends pkt with hdr: ver 72 type 84 len 21584 xid 791752241
"

Can you help me that what is wrong? I have enabled send-to-controller default-behavior 

Looking forward for your guidance.
thanks!
Nadir

Important Announcement